L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Qt : lecture de mémoire hors plage prévue via read_xbm_body

Synthèse de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via read_xbm_body() de Qt, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Produits impactés : Debian, Fedora, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES.
Gravité de ce bulletin : 2/4.
Date de création : 17/08/2020.
Références de cette menace : bulletinjul2020, CVE-2020-17507, DLA-2376-1, DLA-2377-1, FEDORA-2020-8dd86f1b3f, FEDORA-2020-b8091188d0, openSUSE-SU-2020:1452-1, openSUSE-SU-2020:1500-1, openSUSE-SU-2020:1501-1, openSUSE-SU-2020:1530-1, openSUSE-SU-2020:1564-1, openSUSE-SU-2020:1568-1, SUSE-SU-2020:2741-1, SUSE-SU-2020:2742-1, SUSE-SU-2020:2748-1, SUSE-SU-2020:2751-1, SUSE-SU-2020:2760-1, VIGILANCE-VUL-33087.

Description de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via read_xbm_body() de Qt, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille cyber-sécurité concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace.

Solutions pour cette menace 

Debian 9 : nouveaux paquetages qt4-x11.
De nouveaux paquetages sont disponibles :
  Debian 9 : qt4-x11 4:4.8.7+dfsg-11+deb9u1

Debian 9 : nouveaux paquetages qtbase-opensource-src.
De nouveaux paquetages sont disponibles :
  Debian 9 : qtbase-opensource-src 5.7.1+dfsg-3+deb9u3

Fedora 31 : nouveaux paquetages qt.
De nouveaux paquetages sont disponibles :
  Fedora 31 : qt 4.8.7-55.fc31

Fedora 32 : nouveaux paquetages qt.
De nouveaux paquetages sont disponibles :
  Fedora 32 : qt 4.8.7-55.fc32

openSUSE Leap 15.1 : nouveaux paquetages libqt4.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libqt4 4.8.7-lp151.9.3.1

openSUSE Leap 15.1 : nouveaux paquetages libqt5-qtbase.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libqt5-qtbase 5.9.7-lp151.4.6.1

openSUSE Leap 15.2 : nouveaux paquetages libqt4.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : libqt4 4.8.7-lp152.10.3.1

openSUSE Leap 15.2 : nouveaux paquetages libqt5-qtbase.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : libqt5-qtbase 5.12.7-lp152.3.6.1

Oracle Solaris : patch pour logiciels tiers de juillet 2020 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 12 SP2 : nouveaux paquetages libqt5-qtbase.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : libqt5-qtbase 5.6.1-17.16.1

SUSE LE 12 SP3-5 : nouveaux paquetages libqt5-qtbase.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : libqt5-qtbase 5.6.2-6.25.1
  SUSE LE 12 SP4 : libqt5-qtbase 5.6.2-6.25.1
  SUSE LE 12 SP5 : libqt5-qtbase 5.6.2-6.25.1

SUSE LE 15 : nouveaux paquetages libqt5-qtbase.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

SUSE LE 15 RTM : nouveaux paquetages libqt5-qtbase.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : libqt5-qtbase 5.9.4-8.24.1

SUSE LE 15 SP1 : nouveaux paquetages libqt4.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : libqt4 4.8.7-bp151.4.3.1

SUSE LE 15 SP2 : nouveaux paquetages libqt4.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : libqt4 4.8.7-bp152.4.3.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une base de vulnérabilité applicative. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.