L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Rails : boucle infinie via Action View

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une boucle infinie via Action View de Rails, afin de mener un déni de service.
Systèmes impactés : Debian, Fedora, openSUSE Leap, SLES.
Gravité de cette alerte : 2/4.
Date de création : 01/04/2019.
Références de cette alerte : CVE-2019-5419, DLA-1739-1, FEDORA-2019-1cfe24db5c, ibm10881644, openSUSE-SU-2019:1344-1, openSUSE-SU-2019:1527-1, openSUSE-SU-2019:1824-1, openSUSE-SU-2020:1993-1, openSUSE-SU-2020:2000-1, SUSE-SU-2019:1381-1, SUSE-SU-2019:1973-1, SUSE-SU-2020:3036-1, SUSE-SU-2020:3147-1, SUSE-SU-2020:3160-1, VIGILANCE-VUL-28901.

Description de la vulnérabilité 

Un attaquant peut provoquer une boucle infinie via Action View de Rails, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cyber-sécurité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages rails.
De nouveaux paquetages sont disponibles :
  Debian 8 : rails 2:4.1.8-1+deb8u5

Fedora 30 : nouveaux paquetages rubygem.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

IBM BigFix Compliance : version 1.10.1.
La version 1.10.1 est corrigée.

openSUSE Leap 15.0 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : rmt-server 2.1.4-lp150.2.16.1

openSUSE Leap 15.0 : nouveaux paquetages ruby2.5-rubygem-actionpack-5_1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : ruby2.5-rubygem-actionpack-5_1 5.1.4-lp150.2.3.1

openSUSE Leap 15.1 : nouveaux paquetages rmt-server (02/08/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : rmt-server 2.3.1-lp151.2.3.1

openSUSE Leap 15.1 : nouveaux paquetages rmt-server (24/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : rmt-server 2.6.5-lp151.2.18.2

openSUSE Leap 15.2 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : rmt-server 2.6.5-lp152.2.3.1

Redmine : version 3.4.10.
La version 3.4.10 est corrigée :
  http://www.redmine.org/projects/redmine/wiki/Download

Redmine : version 4.0.3.
La version 4.0.3 est corrigée :
  http://www.redmine.org/projects/redmine/wiki/Download

SUSE LE 15 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : rmt-server 2.1.4-3.17.1

SUSE LE 15 RTM : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : rmt-server 2.6.5-3.34.1

SUSE LE 15 SP1 : nouveaux paquetages rmt-server (05/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : rmt-server 2.6.5-3.18.1

SUSE LE 15 SP1 : nouveaux paquetages rmt-server (26/07/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : rmt-server 2.3.1-3.3.3

SUSE LE 15 SP2 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : rmt-server 2.6.5-3.3.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilité de système. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.