L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Rails : obtention d'information via Strong Parameters

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via Strong Parameters de Rails, afin d'obtenir des informations sensibles.
Logiciels vulnérables : Debian, openSUSE Leap, SLES.
Gravité de cette annonce : 2/4.
Date de création : 22/06/2020.
Références de cette vulnérabilité informatique : CVE-2020-8164, DLA-2251-1, DLA-2282-1, DSA-4766-1, openSUSE-SU-2020:1533-1, openSUSE-SU-2020:1536-1, openSUSE-SU-2020:1575-1, openSUSE-SU-2020:1993-1, openSUSE-SU-2020:2000-1, SUSE-SU-2020:2710-1, SUSE-SU-2020:3036-1, SUSE-SU-2020:3147-1, SUSE-SU-2020:3160-1, VIGILANCE-VUL-32593.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via Strong Parameters de Rails, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, openSUSE Leap, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace 

Debian 10 : nouveaux paquetages rails.
De nouveaux paquetages sont disponibles :
  Debian 10 : rails 2:5.2.2.1+dfsg-1+deb10u2

Debian 8 : nouveaux paquetages rails.
De nouveaux paquetages sont disponibles :
  Debian 8 : rails 2:4.1.8-1+deb8u7

Debian 9 : nouveaux paquetages rails.
De nouveaux paquetages sont disponibles :
  Debian 9 : rails 2:4.2.7.1-1+deb9u3

openSUSE Leap 15.1-15.2 : nouveaux paquetages rubygem-actionpack-5_1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : ruby2.5-rubygem-actionpack-5_1 5.1.4-lp151.4.3.1
  openSUSE Leap 15.2 : ruby2.5-rubygem-actionpack-5_1 5.1.4-lp152.5.3.1

openSUSE Leap 15.1 : nouveaux paquetages rmt-server (24/11/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : rmt-server 2.6.5-lp151.2.18.2

openSUSE Leap 15.2 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : rmt-server 2.6.5-lp152.2.3.1

SUSE LE 15 : nouveaux paquetages rubygem-actionpack-5_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : ruby2.5-rubygem-actionpack-5_1 5.1.4-3.6.1
  SUSE LE 15 SP1 : ruby2.5-rubygem-actionpack-5_1 5.1.4-3.6.1
  SUSE LE 15 RTM : ruby2.5-rubygem-actionpack-5_1 5.1.4-3.6.1

SUSE LE 15 RTM : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : rmt-server 2.6.5-3.34.1

SUSE LE 15 SP1 : nouveaux paquetages rmt-server (05/11/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : rmt-server 2.6.5-3.18.1

SUSE LE 15 SP1 : nouveaux paquetages rubygem-actionpack-5_1.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : ruby2.5-rubygem-actionpack 5_1-5.1.4-bp151.2.3.1

SUSE LE 15 SP2 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : rmt-server 2.6.5-3.3.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilité applicative. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.