L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Ruby : buffer overflow via encodes

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via encodes() de Ruby, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels vulnérables : Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 20/04/2017.
Références de cette vulnérabilité informatique : CVE-2014-4975, DSA-3157-1, MDVSA-2014:225, MDVSA-2015:129, openSUSE-SU-2017:1128-1, RHSA-2014:1912-01, RHSA-2014:1913-01, RHSA-2014:1914-01, SUSE-SU-2017:1067-1, USN-2397-1, VIGILANCE-VUL-22519.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via encodes() de Ruby, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille informatique concerne les logiciels ou systèmes comme Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille informatique.

Solutions pour cette menace 

Debian : nouveaux paquetages ruby1.9.1.
De nouveaux paquetages sont disponibles :
  Debian 7 : ruby1.9.1 1.9.3.194-8.1+deb7u3

Mandriva BS2 : nouveaux paquetages ruby.
De nouveaux paquetages sont disponibles :
  Mandriva BS2 : ruby 2.0.0.p598-1.mbs2

Mandriva : nouveaux paquetages ruby.
De nouveaux paquetages sont disponibles :
  Mandriva BS1 : ruby 1.8.7.p374-1.mbs1

openSUSE Leap : nouveaux paquetages ruby2.1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : ruby2.1 2.1.9-10.2
  openSUSE Leap 42.2 : ruby2.1 2.1.9-8.3.2

RHEL 7.0 : nouveaux paquetages ruby.
De nouveaux paquetages sont disponibles :
  RHEL 7 : ruby 2.0.0.353-22.el7_0

RHEL : nouveaux paquetages ruby193-ruby.
De nouveaux paquetages sont disponibles :
  RHEL 6 : ruby193-ruby 1.9.3.484-50.el6
  RHEL 7 : ruby193-ruby 1.9.3.484-50.el7

RHEL : nouveaux paquetages ruby200-ruby.
De nouveaux paquetages sont disponibles :
  RHEL 6 : ruby200-ruby 2.0.0.353-24.el6
  RHEL 7 : ruby200-ruby 2.0.0.353-24.el7

SUSE LE 12 : nouveaux paquetages ruby2.1.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : ruby2.1 2.1.9-15.1
  SUSE LE 12 SP2 : ruby2.1 2.1.9-15.1

Ubuntu : nouveaux paquetages Ruby.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.10 : ruby2.0 2.0.0.484+really457-3ubuntu1.1, ruby2.1 2.1.2-2ubuntu1.1
  Ubuntu 14.04 LTS : ruby1.9.1 1.9.3.484-2ubuntu1.1, ruby2.0 2.0.0.484-1ubuntu2.1
  Ubuntu 12.04 LTS : ruby1.8 1.8.7.352-2ubuntu1.5, ruby1.9.1 1.9.3.0-1ubuntu2.9
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce de vulnérabilité de système. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.