L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de RubyGems : exécution de code via YAML Gem Specification

Synthèse de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via YAML Gem Specification de RubyGems, afin d'exécuter du code.
Produits vulnérables : Debian, Fedora, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 3/4.
Date de création : 13/11/2017.
Références de ce bulletin : CVE-2017-0903, DLA-1421-1, DSA-4031-1, FEDORA-2018-0db545e976, FEDORA-2018-75e780a7c2, RHSA-2017:3485-01, RHSA-2018:0378-01, RHSA-2018:0583-01, RHSA-2018:0585-01, SUSE-SU-2020:1570-1, USN-3553-1, USN-3685-1, USN-3685-2, VIGILANCE-VUL-24414.

Description de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via YAML Gem Specification de RubyGems, afin d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille cyber-sécurité concerne les logiciels ou systèmes comme Debian, Fedora, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille cybersécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages ruby2.1 (16/07/2018).
De nouveaux paquetages sont disponibles :
  Debian 8 : ruby2.1 2.1.5-2+deb8u4

Debian 9 : nouveaux paquetages ruby2.3.
De nouveaux paquetages sont disponibles :
  Debian 9 : ruby2.3 2.3.3-1+deb9u2

Fedora : nouveaux paquetages ruby.
De nouveaux paquetages sont disponibles :
  Fedora 27 : ruby 2.4.3-86.fc27
  Fedora 26 : ruby 2.4.3-86.fc26

RHEL 7.4 : nouveaux paquetages ruby.
De nouveaux paquetages sont disponibles :
  RHEL 7 : ruby 2.0.0.648-33.el7_4

RHEL : nouveaux paquetages rh-ruby22-ruby.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-ruby22-ruby 2.2.9-19.el6
  RHEL 7 : rh-ruby22-ruby 2.2.9-19.el7

RHEL : nouveaux paquetages rh-ruby23-ruby.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-ruby23-ruby 2.3.6-67.el6
  RHEL 7 : rh-ruby23-ruby 2.3.6-67.el7

RHEL : nouveaux paquetages rh-ruby24-ruby.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-ruby24-ruby 2.4.2-86.el6
  RHEL 7 : rh-ruby24-ruby 2.4.2-86.el7

SUSE LE 12 : nouveaux paquetages ruby2.1.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP3 : ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP4 : ruby2.1 2.1.9-19.3.2
  SUSE LE 12 SP5 : ruby2.1 2.1.9-19.3.2

Ubuntu : nouveaux paquetages Ruby.
De nouveaux paquetages sont disponibles :
  Ubuntu 17.10 : ruby2.3 2.3.3-1ubuntu1.3
  Ubuntu 16.04 LTS : ruby2.3 2.3.1-2~16.04.6

Ubuntu : nouveaux paquetages ruby (14/06/2018).
De nouveaux paquetages sont disponibles :
  Ubuntu 17.10 : ruby2.3 2.3.3-1ubuntu1.6
  Ubuntu 16.04 LTS : ruby2.3 2.3.1-2~16.04.10
  Ubuntu 14.04 LTS : ruby1.9.1 1.9.3.484-2ubuntu1.12, ruby1.9.3 1.9.3.484-2ubuntu1.12, ruby2.0 2.0.0.484-1ubuntu2.13+esm1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilités informatiques. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.