L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de SQLite : déni de service via Unused CTE View Recursion

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via Unused CTE View Recursion de SQLite, afin de mener un déni de service.
Logiciels impactés : MySQL Community, MySQL Enterprise, Percona Server, SQLite.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 10/12/2019.
Références de cette annonce : cpuapr2020, CVE-2019-19645, VIGILANCE-VUL-31102.

Description de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via Unused CTE View Recursion de SQLite, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme MySQL Community, MySQL Enterprise, Percona Server, SQLite.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

SQLite : patch pour Unused CTE View Recursion.
Un patch est indiqué dans les sources d'information.

Oracle MySQL : version 5.6.48.
La version 5.6.48 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.7.30.
La version 5.7.30 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 8.0.20.
La version 8.0.20 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Percona Server : version 5.6.48-88.0.
La version 5.6.48-88.0 est corrigée.

Wind River Linux : version 10.19.45.3.
La version 10.19.45.3 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce de vulnérabilités de réseaux. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.