L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de SQLite : déréférencement de pointeur NULL via zipfileUpdate

Synthèse de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via zipfileUpdate() de SQLite, afin de mener un déni de service.
Logiciels vulnérables : Debian, Chrome, Edge Chromium, MySQL Community, MySQL Enterprise, openSUSE Leap, Opera, Percona Server, RHEL, SQLite, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 05/02/2020.
Références de cette vulnérabilité informatique : ADV200002, cpuapr2020, CVE-2019-19925, DSA-4638-1, openSUSE-SU-2020:0189-1, openSUSE-SU-2020:0210-1, openSUSE-SU-2020:0233-1, RHSA-2020:0514-01, RHSA-2020:1810-01, USN-4298-1, USN-4298-2, VIGILANCE-VUL-31519.

Description de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via zipfileUpdate() de SQLite, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille cyber-sécurité concerne les logiciels ou systèmes comme Debian, Chrome, Edge Chromium, MySQL Community, MySQL Enterprise, openSUSE Leap, Opera, Percona Server, RHEL, SQLite, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace.

Solutions pour cette menace 

SQLite : patch pour zipfileUpdate.
Un patch est indiqué dans les sources d'information.

Debian 10 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  Debian 10 : chromium 80.0.3987.132-1~deb10u1

Google Chrome : version 80.0.3987.87.
La version 80.0.3987.87 est corrigée :
  https://www.google.fr/chrome/

Microsoft Edge Chromium : version 80.0.361.48.
La version 80.0.361.48 est corrigée :
  https://portal.msrc.microsoft.com/en-us/security-guidance/advisory/ADV200002

openSUSE Leap 15.1 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : chromium 80.0.3987.87-lp151.2.63.1

Oracle MySQL : version 5.6.48.
La version 5.6.48 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.7.30.
La version 5.7.30 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 8.0.20.
La version 8.0.20 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Percona Server : version 5.6.48-88.0.
La version 5.6.48-88.0 est corrigée.

RHEL 6.10 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  RHEL 6.10 : chromium browser-80.0.3987.87-1.el6_10

RHEL 8 : nouveaux paquetages sqlite (29/04/2020).
De nouveaux paquetages sont disponibles :
  RHEL 8.0-8.1 : sqlite 3.26.0-6.el8

SUSE LE 12 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : chromium 80.0.3987.87-31.1

SUSE LE 15 SP1 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : chromium 80.0.3987.87-bp151.3.59.1

Ubuntu : nouveaux paquetages sqlite3.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : sqlite3 3.29.0-2ubuntu0.2
  Ubuntu 18.04 LTS : sqlite3 3.22.0-1ubuntu0.3
  Ubuntu 16.04 LTS : sqlite3 3.11.0-1ubuntu1.4
  Ubuntu 14.04 ESM : sqlite3 3.8.2-1ubuntu2.2+esm2

Wind River Linux : version 10.19.45.3.
La version 10.19.45.3 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une contre-mesure cybersécurité. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.