L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Slurm : injection SQL

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une injection SQL de Slurm, afin de lire ou modifier des données.
Logiciels vulnérables : Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette annonce : 2/4.
Date de création : 24/07/2019.
Références de cette vulnérabilité informatique : CVE-2019-12838, DLA-2143-1, DSA-4572-1, FEDORA-2019-4ca3a39825, FEDORA-2019-5d0d2619df, openSUSE-SU-2019:2052-1, openSUSE-SU-2019:2536-1, openSUSE-SU-2020:0085-1, SUSE-SU-2019:2229-1, SUSE-SU-2019:2989-1, SUSE-SU-2019:3080-1, SUSE-SU-2020:0110-1, SUSE-SU-2020:0434-1, SUSE-SU-2020:0443-1, SUSE-SU-2020:2607-1, VIGILANCE-VUL-29863.

Description de la vulnérabilité 

Le produit Slurm utilise une base de données.

Cependant, les données provenant de l'utilisateur sont directement insérées dans une requête SQL.

Un attaquant peut donc provoquer une injection SQL de Slurm, afin de lire ou modifier des données.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de menace informatique concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de faille.

Solutions pour cette menace 

Debian 10 : nouveaux paquetages slurm-llnl.
De nouveaux paquetages sont disponibles :
  Debian 10 : slurm-llnl 18.08.5.2-1+deb10u1

Debian 8 : nouveaux paquetages slurm-llnl.
De nouveaux paquetages sont disponibles :
  Debian 8 : slurm-llnl 14.03.9-5+deb8u5

Fedora : nouveaux paquetages slurm.
De nouveaux paquetages sont disponibles :
  Fedora 29 : slurm 18.08.8-1.fc29
  Fedora 30 : slurm 18.08.8-1.fc30

openSUSE Leap 15.0 : nouveaux paquetages slurm.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : slurm 17.11.13-lp150.5.24.1

openSUSE Leap 15.1 : nouveaux paquetages slurm (03/09/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : slurm 18.08.8-lp151.2.3.1

openSUSE Leap 15.1 : nouveaux paquetages slurm (21/01/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : slurm 18.08.9-lp151.2.6.1

SUSE LE 12 : nouveaux paquetages pdsh.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : pdsh 2.33-7.18.1, slurm_18_08 18.08.9-3.5.1

SUSE LE 12 : nouveaux paquetages slurm_20_02.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : slurm_20_02 20.02.3-3.5.1

SUSE LE 12 : nouveaux paquetages slurm (27/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : slurm 17.02.11-6.33.1

SUSE LE 15 : nouveaux paquetages pdsh.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : pdsh 2.33-7.6.1, slurm 18_08-18.08.9-1.5.2
  SUSE LE 15 SP1 : pdsh 2.33-7.6.1

SUSE LE 15 : nouveaux paquetages slurm.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : slurm 18.08.8-3.4.1
  SUSE LE 15 SP1 : slurm 18.08.8-3.4.1

SUSE LE 15 SP1 : nouveaux paquetages slurm.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : slurm 18.08.9-3.10.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilités de réseaux. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.