L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Squid : Cross Site Scripting via cachemgr.cgi

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un Cross Site Scripting via cachemgr.cgi de Squid, afin d'exécuter du code JavaScript dans le contexte du site web.
Systèmes vulnérables : Debian, openSUSE Leap, Solaris, RHEL, Squid, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 08/07/2019.
Références de cette faille : 4957, CERTFR-2019-AVI-332, CVE-2019-13345, DLA-1847-1, DLA-2278-1, DLA-2278-2, DLA-2278-3, DSA-4507-1, openSUSE-SU-2019:1963-1, openSUSE-SU-2019:2540-1, openSUSE-SU-2019:2541-1, RHSA-2019:3476-01, RHSA-2020:1068-01, SQUID-2019:6, SUSE-SU-2019:2089-1, SUSE-SU-2019:2092-1, SUSE-SU-2019:2975-1, SUSE-SU-2019:3067-1, SUSE-SU-2020:14460-1, USN-4059-1, USN-4059-2, VIGILANCE-VUL-29702.

Description de la vulnérabilité 

Un attaquant peut provoquer un Cross Site Scripting via cachemgr.cgi de Squid, afin d'exécuter du code JavaScript dans le contexte du site web.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, openSUSE Leap, Solaris, RHEL, Squid, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace 

Squid cache : version 4.8.
La version 4.8 est corrigée :
  http://www.squid-cache.org/Versions/v4/

Squid : patch pour cachemgr.cgi.
Un patch est disponible :
  Squid 3.x : http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-5730c2b5cb56e7639dc423dd62651c8736a54e35.patch
  Squid 4 : http://www.squid-cache.org/Versions/v4/changesets/squid-4-be1dc8614e7514103ba84d4067ed6fd15ab8f82e.patch

Debian 10 : nouveaux paquetages squid.
De nouveaux paquetages sont disponibles :
  Debian 10 : squid 4.6-1+deb10u1

Debian 8 : nouveaux paquetages squid3.
De nouveaux paquetages sont disponibles :
  Debian 8 : squid3 3.4.8-6+deb8u7

Debian 9 : nouveaux paquetages squid3.
De nouveaux paquetages sont disponibles :
  Debian 9 : squid3 3.5.23-5+deb9u4

openSUSE Leap 15 : nouveaux paquetages squid (21/08/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : squid 4.8-lp150.9.1
  openSUSE Leap 15.1 : squid 4.8-lp151.2.3.1

openSUSE Leap 15 : nouveaux paquetages squid (22/11/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : squid 4.9-lp150.13.1
  openSUSE Leap 15.1 : squid 4.9-lp151.2.7.1

Oracle Solaris : patch pour logiciels tiers de octobre 2019 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7 : nouveaux paquetages squid.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.7 : squid 3.5.20-15.el7

RHEL 8 : nouveau module squid-4.
Le module suivant est mis à jour :
  RHEL 8 Module : squid:4

SUSE LE 11 SP3-4 : nouveaux paquetages squid3.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : squid3 3.1.23-8.16.37.12.1
  SUSE LE 11 SP4 : squid3 3.1.23-8.16.37.12.1

SUSE LE 12 : nouveaux paquetages squid.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : squid 3.5.21-26.17.1
  SUSE LE 12 SP3 : squid 3.5.21-26.17.1
  SUSE LE 12 SP4 : squid 3.5.21-26.17.1

SUSE LE 12 SP5 : nouveaux paquetages squid (26/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : squid 4.9-4.3.2

SUSE LE 15 : nouveaux paquetages squid (09/08/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : squid 4.8-5.8.1
  SUSE LE 15 SP1 : squid 4.8-5.8.1

SUSE LE 15 : nouveaux paquetages squid (15/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : squid 4.9-5.11.1
  SUSE LE 15 SP1 : squid 4.9-5.11.1

Ubuntu : nouveaux paquetages squid.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : squid 4.4-1ubuntu2.1
  Ubuntu 18.04 LTS : squid3 3.5.27-1ubuntu1.2
  Ubuntu 16.04 LTS : squid3 3.5.12-1ubuntu7.7
  Ubuntu 12.04 ESM : squid3 3.1.19-1ubuntu3.12.04.9
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilité applicative. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.