L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Wireshark : attaque par format via PN-DCP

Synthèse de la vulnérabilité 

Un attaquant peut envoyer des données PN-DCP illicites afin de mener un déni de service ou de faire exécuter du code sur Wireshark.
Produits impactés : Debian, Ethereal, Fedora, NLD, OES, openSUSE, RHEL, SLES, Wireshark.
Gravité de ce bulletin : 2/4.
Date de création : 31/03/2009.
Références de cette menace : BID-34291, CERTA-2009-AVI-139, CVE-2009-1210, DSA-1785-1, FEDORA-2009-3599, RHSA-2009:1100-01, SUSE-SR:2009:011, VIGILANCE-VUL-8577, wnpa-sec-2009-02.

Description de la vulnérabilité 

Le produit Wireshark intercepte et affiche des trames réseau.

Le protocole PROFINET est utilisé dans les réseaux industriels (sur Ethernet ou tunnelé dans DCE/RPC). Le protocole PN-DCP (PROFINET Discovery and basic Configuration Protocol) est supporté par Wireshark.

Le protocole PN-DCP utilise plusieurs champs :
 - Device ID : identifiant du périphérique
 - Device Role : type de périphérique
 - Manufacturer : constructeur
 - Name Of Station : nom de la station

Cependant, si le nom de la station contient des caractères de formatage, une attaque par format se produit dans le dissecteur Wireshark.

Un attaquant peut donc envoyer des données PN-DCP illicites afin de mener un déni de service ou de faire exécuter du code sur Wireshark.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Debian, Ethereal, Fedora, NLD, OES, openSUSE, RHEL, SLES, Wireshark.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

Wireshark : version 1.0.7.
La version 1.0.7 est corrigée :
  http://www.wireshark.org/

Debian : nouveaux paquetages wireshark (04/05/2009).
De nouveaux paquetages sont disponibles :
  http://security.debian.org/pool/updates/main/w/wireshark/wireshark_1.0.2-3+lenny5_*.deb

Fedora 10 : nouveaux paquetages wireshark.
De nouveaux paquetages sont disponibles :
  wireshark-1.0.7-1.fc10

RHEL : nouveaux paquetages wireshark.
De nouveaux paquetages sont disponibles :
Red Hat Enterprise Linux version 3: wireshark-1.0.8-EL3.1
Red Hat Enterprise Linux version 4: wireshark-1.0.8-1.el4_8.1
Red Hat Enterprise Linux version 5: wireshark-1.0.8-1.el5_3.1

SUSE : nouveaux paquetages (09/06/2009).
De nouveaux paquetages sont disponibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de sécurité informatique. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.