L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Xen : déni de service via GNTTABOP_map_grant

Synthèse de la vulnérabilité 

Un attaquant, dans un système invité, peut provoquer une erreur fatale via GNTTABOP_map_grant() de Xen, afin de mener un déni de service sur le système hôte.
Produits vulnérables : XenServer, Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Xen.
Gravité de cette faille : 1/4.
Date de création : 14/04/2020.
Références de ce bulletin : CERTFR-2020-AVI-205, CERTFR-2020-AVI-213, CTX270837, CVE-2020-11743, DSA-4723-1, FEDORA-2020-295ed0b1e0, FEDORA-2020-cbc3149753, openSUSE-SU-2020:0599-1, SUSE-SU-2020:1124-1, SUSE-SU-2020:1138-1, SUSE-SU-2020:1139-1, SUSE-SU-2020:1634-1, VIGILANCE-VUL-32010, XSA-316.

Description de la vulnérabilité 

Un attaquant, dans un système invité, peut provoquer une erreur fatale via GNTTABOP_map_grant() de Xen, afin de mener un déni de service sur le système hôte.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace sécurité concerne les logiciels ou systèmes comme XenServer, Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Xen.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de faille est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité.

Solutions pour cette menace 

Xen : patch pour GNTTABOP_map_grant.
Un patch est disponible :
  http://xenbits.xen.org/xsa/xsa316/xsa316-linux.patch
  http://xenbits.xen.org/xsa/xsa316/xsa316-xen.patch

Citrix XenServer/Hypervisor : patch.
Un patch est disponible :
  Citrix Hypervisor 8.1 : CTX270795 https://support.citrix.com/article/CTX270795
  Citrix Hypervisor 8.0 : CTX270794 https://support.citrix.com/article/CTX270794
  Citrix XenServer 7.1 LTSR CU2 : CTX270793 https://support.citrix.com/article/CTX270793
  Citrix XenServer 7.0 : CTX270792 https://support.citrix.com/article/CTX270792

Debian 10 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Debian 10 : xen 4.11.4+24-gddaaccbbab-1~deb10u1

Fedora 30-31 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Fedora 30 : xen 4.11.4-1.fc30
  Fedora 31 : xen 4.12.2-3.fc31

openSUSE Leap 15.1 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : xen 4.12.2_04-lp151.2.15.1

SUSE LE 12 SP4, SP5 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : xen 4.11.3_04-2.23.1
  SUSE LE 12 SP5 : xen 4.12.2_04-3.11.1

SUSE LE 15 RTM : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : xen 4.10.4_10-3.31.1

SUSE LE 15 SP1 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : xen 4.12.2_04-3.15.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille cybersécurité. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.