L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Xen : élévation de privilèges via IOMMU Read/write DMA Access

Synthèse de la vulnérabilité 

Un attaquant, dans un système invité, peut contourner les restrictions via IOMMU Read/write DMA Access de Xen, afin d'élever ses privilèges sur le système hôte.
Logiciels impactés : XenServer, Debian, SUSE Linux Enterprise Desktop, SLES, Xen.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 18/02/2021.
Références de cette annonce : CERTFR-2021-AVI-135, CERTFR-2021-AVI-460, CTX316324, CVE-2021-27379, DSA-4888-1, SUSE-SU-2021:1250-1, SUSE-SU-2021:1251-1, SUSE-SU-2021:1252-1, SUSE-SU-2021:1268-1, VIGILANCE-VUL-34612, XSA-366.

Description de la vulnérabilité 

Un attaquant, dans un système invité, peut contourner les restrictions via IOMMU Read/write DMA Access de Xen, afin d'élever ses privilèges sur le système hôte.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce sécurité concerne les logiciels ou systèmes comme XenServer, Debian, SUSE Linux Enterprise Desktop, SLES, Xen.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de faille.

Solutions pour cette menace 

Xen : patch pour IOMMU Read/write DMA Access.
Un patch est disponible :
  http://xenbits.xen.org/xsa/xsa366-4.11.patch

Citrix Hypervisor : patch.
Un patch est disponible :
  Citrix Hypervisor 8.2 LTSR : CTX313807 https://support.citrix.com/article/CTX313807
  Citrix XenServer 7.1 LTSR CU2 : CTX313806 https://support.citrix.com/article/CTX313806

Debian 10 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Debian 10 : xen 4.11.4+99-g8bce4698f6-1

SUSE LE 12 SP2 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : xen 4.7.6_14-43.76.1

SUSE LE 12 SP3 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : xen 4.9.4_16-3.83.1

SUSE LE 12 SP4 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : xen 4.11.4_16-2.51.1

SUSE LE 15 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : xen 4.10.4_24-3.56.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une contre-mesure de vulnérabilités informatiques. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.