L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Xen : obtention d'information via x86 FPU/XMM

Synthèse de la vulnérabilité 

Un attaquant, situé dans un système invité, peut lire un fragment de la mémoire de x86 FPU/XMM de Xen, afin d'obtenir des informations sensibles.
Systèmes vulnérables : XenServer, Debian, Fedora, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Xen.
Gravité de cette menace : 1/4.
Date de création : 17/12/2015.
Références de cette faille : CERTFR-2015-AVI-551, CERTFR-2015-AVI-556, CTX203879, CVE-2015-8555, DLA-479-1, DSA-3519-1, FEDORA-2015-c44bd3e0fa, FEDORA-2015-d8253e2b1d, openSUSE-SU-2016:0123-1, openSUSE-SU-2016:0124-1, openSUSE-SU-2016:0126-1, SUSE-SU-2016:0658-1, SUSE-SU-2016:0873-1, SUSE-SU-2016:0955-1, SUSE-SU-2016:1154-1, SUSE-SU-2016:1318-1, SUSE-SU-2016:1745-1, VIGILANCE-VUL-18554, XSA-165.

Description de la vulnérabilité 

Les instructions XSAVE et XRSTOR permettent de sauver et restaurer l'état du processeur.

Cependant, lorsque Xen est sur un processeur x86 sans XSAVE/XRSTOR, un système invité peut lire la pile FPU et les registres XMM précédents.

Un attaquant, situé dans un système invité, peut donc lire un fragment de la mémoire de x86 FPU/XMM de Xen, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis sécurité concerne les logiciels ou systèmes comme XenServer, Debian, Fedora, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Xen.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte sécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité.

Solutions pour cette menace 

Xen : patch pour x86 FPU/XMM.
Un patch est disponible :
  http://xenbits.xen.org/xsa/advisory-165.html

Citrix XenServer : patch.
Un patch est indiqué dans les sources d'information.

Debian 7 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Debian 7 : xen 4.1.6.1-1+deb7u1

Debian : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Debian 8 : xen 4.4.1-9+deb8u4

Fedora : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  Fedora 22 : xen 4.5.2-6.fc22
  Fedora 23 : xen 4.5.2-6.fc23

openSUSE 13.1 : nouveaux paquetages xen (15/01/2016).
De nouveaux paquetages sont disponibles :
  openSUSE 13.1 : xen 4.3.4_10-53.1

openSUSE 13.2 : nouveaux paquetages xen (15/01/2016).
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : xen 4.4.3_08-36.1

openSUSE Leap 42.1 : nouveaux paquetages xen (15/01/2016).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : xen 4.5.2_04-9.2

SUSE LE 10 : nouveaux paquetages xen (07/03/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 10 SP4 : xen 3.2.3_17040_46-0.23.2

SUSE LE 11 SP2 : nouveaux paquetages xen (27/04/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP2 : xen 4.1.6_08-26.1

SUSE LE 11 SP3 : nouveaux paquetages xen (06/07/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : xen-kmp-default 4.2.5_20_3.0.101_0.47.79-24.9, xen-libs 4.2.5_20-24.9, xen-tools-domU 4.2.5_20-24.9

SUSE LE 11 SP4 : nouveaux paquetages xen (05/04/2016).
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : xen 4.4.4_02-32.1

SUSE LE 12 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : xen 4.4.4_02-22.19.1

SUSE LE 12 SP1 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : xen 4.5.2_06-7.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilités informatiques. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.