L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Zend Framework : injection de données via zf-apigility

Synthèse de la vulnérabilité 

Un attaquant peut injecter des données incorrectes dans la base via zf-apigility de Zend Framework, afin d'altérer le fonctionnement du service.
Systèmes impactés : Zend Framework.
Gravité de cette alerte : 2/4.
Date de création : 06/06/2014.
Références de cette alerte : AG2014-01, VIGILANCE-VUL-14849.

Description de la vulnérabilité 

La classe ZF\Apigility\DbConnectedResource manipule des données avant de les stocker en base.

Cependant, les données provenant de l'utilisateur, et traitées par les méthodes update() et patch(), sont directement insérées dans la base, sans être filtrées.

Un attaquant peut donc injecter des données incorrectes dans la base via zf-apigility de Zend Framework, afin d'altérer le fonctionnement du service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Zend Framework.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

zf-apigility : version 1.0.2.
La version 1.0.2 est corrigée :
  https://github.com/zfcampus/zf-apigility
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilités informatiques. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.