L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de curl : obtention d'authentifiants via le cache de connexions

Synthèse de la vulnérabilité 

Un attaquant contrôlant un serveur HTTP peut recevoir d'un client curl des noms d'utilisateurs et les mots de passe associés.
Systèmes impactés : SDS, SES, SNS, OpenOffice, curl, Fedora, openSUSE, Solaris, Puppet, Slackware.
Gravité de cette alerte : 2/4.
Date de création : 17/06/2015.
Références de cette alerte : cpuoct2018, CVE-2015-3236, FEDORA-2015-10155, openSUSE-SU-2015:1135-1, SSA:2015-302-01, STORM-2019-002, VIGILANCE-VUL-17153.

Description de la vulnérabilité 

Le produit curl est entre autres une bibliothèque cliente pour HTTP.

Elle peut stocker et transmettre des authentifiants pour le mode d'authentification "HTTP Basic". Elle conserve des connexions ouvertes pour réutilisation éventuelle pour une nouvelle requête (cf. en-tête HTTP "Connection"). Cependant, la fonction de réinitialisation du client curl_easy_reset() n'efface pas ces authentifiants dans les descripteurs de connexions conservés. Donc, lorsque le client accède à une ressource protégée puis une ressource publique pour laquelle une connexion du cache est disponible, curl envoie les authentifiants provenant du descripteur de connexion du cache.

Un attaquant contrôlant un serveur HTTP peut donc recevoir d'un client curl des noms d'utilisateurs et les mots de passe associés.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille concerne les logiciels ou systèmes comme SDS, SES, SNS, OpenOffice, curl, Fedora, openSUSE, Solaris, Puppet, Slackware.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de serveur internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cybersécurité.

Solutions pour cette menace 

curl : version 7.43.0.
La version 7.43.0 est corrigée :
  http://curl.haxx.se/download/curl-7.43.0.tar.gz

Apache OpenOffice : version 4.1.6.
La version 4.1.6 est corrigée :
  https://www.openoffice.org/download/

Fedora 22 : nouveaux paquetages curl.
De nouveaux paquetages sont disponibles :
  Fedora 22 : curl 7.40.0-5.fc22

openSUSE 13 : nouveaux paquetages curl.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : curl 7.42.1-16.1
  openSUSE 13.1 : curl 7.42.1-2.47.1

Oracle Solaris : CPU de octobre 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2451130.1

Puppet Agent : version 1.2.2.
La version 1.2.2 est corrigée :
  https://puppetlabs.com/

Slackware : nouveaux paquetages curl.
De nouveaux paquetages sont disponibles :
  Slackware 13.0 : curl 7.45.0-*-1_slack13.0
  Slackware 13.1 : curl 7.45.0-*-1_slack13.1
  Slackware 13.37 : curl 7.45.0-*-1_slack13.37
  Slackware 14.0 : curl 7.45.0-*-1_slack14.0
  Slackware 14.1 : curl 7.45.0-*-1_slack14.1

Stormshield : solution pour curl.
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilités informatiques. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.