L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de fetchmail : déni de service en mode verbose

Synthèse de la vulnérabilité 

Lorsque fetchmail est utilisé en mode verbose, un attaquant peut créer un message trop long afin de le stopper.
Logiciels impactés : Fedora, Mandriva Linux, RHEL, Slackware, Unix (plateforme) ~ non exhaustif.
Gravité de cette vulnérabilité informatique : 1/4.
Date de création : 18/06/2008.
Références de cette annonce : 354291, CVE-2008-2711, FEDORA-2008-5789, FEDORA-2008-5800, fetchmail-SA-2007-02, fetchmail-SA-2008-01, MDVSA-2008:117, RHSA-2009:1427-01, SSA:2008-210-01, VIGILANCE-VUL-7900.

Description de la vulnérabilité 

Le programme fetchmail télécharge des emails depuis un serveur POP ou IMAP et les délivre selon sa configuration.

Lorsque fetchmail est utilisé en mode verbose (-vv ou -vvv), il réécrit les entêtes. Cependant, si la taille de l'entête dépasse 2048 caractères, une erreur de produit et stoppe fetchmail.

Un attaquant peut donc créer un email illicite afin de créer un déni de service lors de son téléchargement en mode verbose.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte cybersécurité concerne les logiciels ou systèmes comme Fedora, Mandriva Linux, RHEL, Slackware, Unix (plateforme) ~ non exhaustif.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de menace est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de menace informatique.

Solutions pour cette menace 

fetchmail : version 6.3.9.
La version 6.3.9 est corrigée :
  http://developer.berlios.de/project/showfiles.php?group_id=1824

Fedora : nouveaux paquetages fetchmail.
De nouveaux paquetages sont disponibles :
  fetchmail-6.3.8-4.fc8
  fetchmail-6.3.8-7.fc9

Mandriva : nouveaux paquetages fetchmail.
De nouveaux paquetages sont disponibles :
 
 Mandriva Linux 2007.1:
 77b20fed31ffc8f26b91b289b1735742 2007.1/i586/fetchmail-6.3.6-1.3mdv2007.1.i586.rpm
 48d0099eb291e7ed6de0ee268f483be4 2007.1/i586/fetchmailconf-6.3.6-1.3mdv2007.1.i586.rpm
 efc2563d1ab82b6d0f32762caefa2439 2007.1/i586/fetchmail-daemon-6.3.6-1.3mdv2007.1.i586.rpm
 a208f8c8096e5204fa17f749c369fa4c 2007.1/SRPMS/fetchmail-6.3.6-1.3mdv2007.1.src.rpm
 Mandriva Linux 2007.1/X86_64:
 f9a9f4086f217c01330a39db69976a80 2007.1/x86_64/fetchmail-6.3.6-1.3mdv2007.1.x86_64.rpm
 64fbf2cba15a7871884859263832effa 2007.1/x86_64/fetchmailconf-6.3.6-1.3mdv2007.1.x86_64.rpm
 826669b445b5107862a07d9b0e75bfb9 2007.1/x86_64/fetchmail-daemon-6.3.6-1.3mdv2007.1.x86_64.rpm
 a208f8c8096e5204fa17f749c369fa4c 2007.1/SRPMS/fetchmail-6.3.6-1.3mdv2007.1.src.rpm
 Mandriva Linux 2008.0:
 44bf754420177032e7720aa6385d92dd 2008.0/i586/fetchmail-6.3.8-4.1mdv2008.0.i586.rpm
 090719d821a64ebc3ac486bfc1b90363 2008.0/i586/fetchmailconf-6.3.8-4.1mdv2008.0.i586.rpm
 836dbd2dda8acb1267bfaedfb342a1b7 2008.0/i586/fetchmail-daemon-6.3.8-4.1mdv2008.0.i586.rpm
 67ccd52b855904cdab9c59403ca75144 2008.0/SRPMS/fetchmail-6.3.8-4.1mdv2008.0.src.rpm
 Mandriva Linux 2008.0/X86_64:
 ffd538cbfe8476577c172088e6ab6ccd 2008.0/x86_64/fetchmail-6.3.8-4.1mdv2008.0.x86_64.rpm
 bba7c59daafdf2b922fdc49c8289e950 2008.0/x86_64/fetchmailconf-6.3.8-4.1mdv2008.0.x86_64.rpm
 5ba2c860cdf76975243aa95f637e5bfa 2008.0/x86_64/fetchmail-daemon-6.3.8-4.1mdv2008.0.x86_64.rpm
 67ccd52b855904cdab9c59403ca75144 2008.0/SRPMS/fetchmail-6.3.8-4.1mdv2008.0.src.rpm
 Mandriva Linux 2008.1:
 3183a6eecffd1d3f28cc653d7c1154cb 2008.1/i586/fetchmail-6.3.8-7.1mdv2008.1.i586.rpm
 332305442e6617b3c6e8477b8873d671 2008.1/i586/fetchmailconf-6.3.8-7.1mdv2008.1.i586.rpm
 64f5cd910f5e25a82eb673fc3e017f7d 2008.1/i586/fetchmail-daemon-6.3.8-7.1mdv2008.1.i586.rpm
 b4625b074ae3f30016eca5beedddda85 2008.1/SRPMS/fetchmail-6.3.8-7.1mdv2008.1.src.rpm
 Mandriva Linux 2008.1/X86_64:
 afa1fe93700e16c207b26466c379dba0 2008.1/x86_64/fetchmail-6.3.8-7.1mdv2008.1.x86_64.rpm
 38fc1cb8e9b6a838fd7aaac05cbdfd6c 2008.1/x86_64/fetchmailconf-6.3.8-7.1mdv2008.1.x86_64.rpm
 96413fc60a0d5c961e69c5ecae03001c 2008.1/x86_64/fetchmail-daemon-6.3.8-7.1mdv2008.1.x86_64.rpm
 b4625b074ae3f30016eca5beedddda85 2008.1/SRPMS/fetchmail-6.3.8-7.1mdv2008.1.src.rpm
 Corporate 3.0:
 8ea71c3755960b09d7f24de64d26f8cd corporate/3.0/i586/fetchmail-6.2.5-3.7.C30mdk.i586.rpm
 d56338486e23c1b4bed562feaeaa9a7b corporate/3.0/i586/fetchmailconf-6.2.5-3.7.C30mdk.i586.rpm
 2a9a1ea5b35a6079de582d4a023263e3 corporate/3.0/i586/fetchmail-daemon-6.2.5-3.7.C30mdk.i586.rpm
 9b1b9c5cab6b2c81b11f26b7587aa096 corporate/3.0/SRPMS/fetchmail-6.2.5-3.7.C30mdk.src.rpm
 Corporate 3.0/X86_64:
 84203e2a84ad1772a78ba5b5c9c33a2f corporate/3.0/x86_64/fetchmail-6.2.5-3.7.C30mdk.x86_64.rpm
 3d6dbf92ffc9101a765decbe530437c9 corporate/3.0/x86_64/fetchmailconf-6.2.5-3.7.C30mdk.x86_64.rpm
 156c24d040be43da88842d5ee27b40ba corporate/3.0/x86_64/fetchmail-daemon-6.2.5-3.7.C30mdk.x86_64.rpm
 9b1b9c5cab6b2c81b11f26b7587aa096 corporate/3.0/SRPMS/fetchmail-6.2.5-3.7.C30mdk.src.rpm
 Corporate 4.0:
 1f69a551eb9f1afbbe6e42be597b1ba1 corporate/4.0/i586/fetchmail-6.2.5-11.6.20060mlcs4.i586.rpm
 421360e6dee540b9d4e28b274724e604 corporate/4.0/i586/fetchmailconf-6.2.5-11.6.20060mlcs4.i586.rpm
 6451f4757de94be5d5a5c8542c8e703b corporate/4.0/i586/fetchmail-daemon-6.2.5-11.6.20060mlcs4.i586.rpm
 1c3a942647354d1de2b6abe0253e02b0 corporate/4.0/SRPMS/fetchmail-6.2.5-11.6.20060mlcs4.src.rpm
 Corporate 4.0/X86_64:
 c9101af89574256bba203cd4f7e215c1 corporate/4.0/x86_64/fetchmail-6.2.5-11.6.20060mlcs4.x86_64.rpm
 938b40ccf9dcade9edf7347fdd42324b corporate/4.0/x86_64/fetchmailconf-6.2.5-11.6.20060mlcs4.x86_64.rpm
 990a1f0e7642ce75a4923a24990b0b68 corporate/4.0/x86_64/fetchmail-daemon-6.2.5-11.6.20060mlcs4.x86_64.rpm
 1c3a942647354d1de2b6abe0253e02b0 corporate/4.0/SRPMS/fetchmail-6.2.5-11.6.20060mlcs4.src.rpm

RHEL : nouveaux paquetages fetchmail.
De nouveaux paquetages sont disponibles :
Red Hat Enterprise Linux version 3: fetchmail-6.2.0-3.el3.5
Red Hat Enterprise Linux version 4: fetchmail-6.2.5-6.0.1.el4_8.1
Red Hat Enterprise Linux version 5: fetchmail-6.3.6-1.1.el5_3.1

Slackware : nouveaux paquetages fetchmail.
De nouveaux paquetages sont disponibles :
Slackware 8.1:
ftp://ftp.slackware.com/pub/slackware/slackware-8.1/patches/packages/fetchmail-6.3.8-i386-1_slack8.1.tgz
Slackware 9.0:
ftp://ftp.slackware.com/pub/slackware/slackware-9.0/patches/packages/fetchmail-6.3.8-i386-1_slack9.0.tgz
Slackware 9.1:
ftp://ftp.slackware.com/pub/slackware/slackware-9.1/patches/packages/fetchmail-6.3.8-i486-1_slack9.1.tgz
Slackware 10.0:
ftp://ftp.slackware.com/pub/slackware/slackware-10.0/patches/packages/fetchmail-6.3.8-i486-1_slack10.0.tgz
Slackware 10.1:
ftp://ftp.slackware.com/pub/slackware/slackware-10.1/patches/packages/fetchmail-6.3.8-i486-1_slack10.1.tgz
Slackware 10.2:
ftp://ftp.slackware.com/pub/slackware/slackware-10.2/patches/packages/fetchmail-6.3.8-i486-1_slack10.2.tgz
Slackware 11.0:
ftp://ftp.slackware.com/pub/slackware/slackware-11.0/patches/packages/fetchmail-6.3.8-i486-1_slack11.0.tgz
Slackware 12.0:
ftp://ftp.slackware.com/pub/slackware/slackware-12.0/patches/packages/fetchmail-6.3.8-i486-3_slack12.0.tgz
Slackware 12.1:
ftp://ftp.slackware.com/pub/slackware/slackware-12.1/patches/packages/fetchmail-6.3.8-i486-3_slack12.1.tgz
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilité informatique. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.