L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de glibc : débordement d'entier via stdlib/canonicalize.c

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un débordement d'entier via stdlib/canonicalize.c de glibc, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Unisphere EMC, VNX Operating Environment, VNX Series, BladeCenter, openSUSE Leap, Oracle Communications, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de ce bulletin : 2/4.
Date de création : 06/06/2018.
Références de cette menace : cpuapr2019, CVE-2018-11236, DSA-2019-114, DSA-2019-197, ibm10880783, openSUSE-SU-2018:1600-1, openSUSE-SU-2018:2159-1, RHSA-2018:3092-01, SUSE-SU-2018:1562-1, SUSE-SU-2018:1991-1, SUSE-SU-2018:2185-1, SUSE-SU-2018:2187-1, SUSE-SU-2018:2302-1, VIGILANCE-VUL-26325.

Description de la vulnérabilité 

Un attaquant peut provoquer un débordement d'entier via stdlib/canonicalize.c de glibc, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille cyber-sécurité concerne les logiciels ou systèmes comme Unisphere EMC, VNX Operating Environment, VNX Series, BladeCenter, openSUSE Leap, Oracle Communications, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace.

Solutions pour cette menace 

Dell EMC Unisphere Central : version 4.0.8.23220.
La version 4.0.8.23220 est corrigée :
  https://www.dell.com/support/

Dell EMC VNXe : version MR4 Service Pack 5.
La version MR4 Service Pack 5 est corrigée :
  https://www.dell.com/support/

IBM BladeCenter : patch pour glibc.
Un patch est disponible :
  http://www.ibm.com/support/fixcentral/

openSUSE Leap 15.0 : nouveaux paquetages glibc (02/08/2018).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : glibc 2.26-lp150.11.6.120

openSUSE Leap 42.3 : nouveaux paquetages glibc.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : glibc 2.22-19.1

Oracle Communications : CPU de avril 2019.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2518758.1
  https://support.oracle.com/rs?type=doc&id=2518763.1
  https://support.oracle.com/rs?type=doc&id=2522151.1
  https://support.oracle.com/rs?type=doc&id=2519787.1
  https://support.oracle.com/rs?type=doc&id=2522126.1
  https://support.oracle.com/rs?type=doc&id=2522123.1
  https://support.oracle.com/rs?type=doc&id=2518753.1
  https://support.oracle.com/rs?type=doc&id=2522121.1
  https://support.oracle.com/rs?type=doc&id=2528862.1
  https://support.oracle.com/rs?type=doc&id=2518754.1

RHEL 7 : nouveaux paquetages glibc.
De nouveaux paquetages sont disponibles :
  RHEL 7 : glibc 2.17-260.el7

SUSE LE 11 : nouveaux paquetages glibc.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : glibc 2.11.3-17.110.14.1
  SUSE LE 11 SP4 : glibc 2.11.3-17.110.14.1

SUSE LE 12 RTM : nouveaux paquetages glibc (06/08/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : glibc 2.19-22.27.958

SUSE LE 12 SP1 : nouveaux paquetages glibc.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : glibc 2.19-40.16.950

SUSE LE 12 SP2/3 : nouveaux paquetages glibc.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : glibc 2.22-62.13.2
  SUSE LE 12 SP3 : glibc 2.22-62.13.2

SUSE LE 15 : nouveaux paquetages glibc.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : glibc 2.26-13.3.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilités logicielles. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.