L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de jackson-databind : lecture de fichier via Polymorphic Typing JSON Message

Synthèse de la vulnérabilité 

Un attaquant local peut lire un fichier via Polymorphic Typing JSON Message de jackson-databind, afin d'obtenir des informations sensibles.
Logiciels vulnérables : Debian, Fedora, JBoss EAP par Red Hat, Red Hat SSO, SAS Add-in for Microsoft Office, SAS Analytics Pro, Base SAS Software, SAS BI Server, SAS Enterprise Guide, SAS Grid Computing, SAS Management Console, SAS OLAP Server, SAS SAS/ACCESS, SAS SAS/AF, SAS SAS/CONNECT, SAS SAS/EIS, SAS SAS/ETS, SAS SAS/FSP, SAS SAS/GRAPH, SAS SAS/IML, SAS SAS/INSIGHT, SAS SAS/OR, SAS SAS/STAT, SAS SAS/Web Report Studio.
Gravité de cette annonce : 2/4.
Date de création : 24/06/2019.
Références de cette vulnérabilité informatique : CVE-2019-12814, DLA-1831-1, FEDORA-2019-ae6a703b8f, FEDORA-2019-fb23eccc03, RHSA-2019:2935-01, RHSA-2019:2936-01, RHSA-2019:2937-01, RHSA-2019:2938-01, RHSA-2019:3044-01, RHSA-2019:3045-01, RHSA-2019:3046-01, RHSA-2019:3050-01, VIGILANCE-VUL-29605.

Description de la vulnérabilité 

Un attaquant local peut lire un fichier via Polymorphic Typing JSON Message de jackson-databind, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de menace concerne les logiciels ou systèmes comme Debian, Fedora, JBoss EAP par Red Hat, Red Hat SSO, SAS Add-in for Microsoft Office, SAS Analytics Pro, Base SAS Software, SAS BI Server, SAS Enterprise Guide, SAS Grid Computing, SAS Management Console, SAS OLAP Server, SAS SAS/ACCESS, SAS SAS/AF, SAS SAS/CONNECT, SAS SAS/EIS, SAS SAS/ETS, SAS SAS/FSP, SAS SAS/GRAPH, SAS SAS/IML, SAS SAS/INSIGHT, SAS SAS/OR, SAS SAS/STAT, SAS SAS/Web Report Studio.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de vulnérabilité.

Solutions pour cette menace 

Apache ZooKeeper : version 3.5.6.
La version 3.5.6 est corrigée :
  http://zookeeper.apache.org/releases.html#download

Debian 8 : nouveaux paquetages jackson-databind.
De nouveaux paquetages sont disponibles :
  Debian 8 : jackson-databind 2.4.2-2+deb8u7

Fedora : nouveaux paquetages jackson.
De nouveaux paquetages sont disponibles :
  Fedora 30 : jackson-annotations 2.9.9-1.fc30, jackson-core 2.9.9-1.fc30, jackson-bom 2.9.9-1.fc30, jackson-databind 2.9.9.3-1.fc30
  Fedora 29 : jackson-annotations 2.9.9-1.fc29, jackson-core 2.9.9-1.fc29, jackson-bom 2.9.9-1.fc29, jackson-databind 2.9.9.3-1.fc29

Red Hat JBoss EAP : version 7.2.4.
La version 7.2.4 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=7.2

Red Hat Single Sign-On : version 7.3.4.
La version 7.3.4 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=core.service.rhsso&downloadType=securityPatches&version=7.3

SAS : version 9.4M6 TS1M6 11-19-2019.
La version 9.4M6 TS1M6 11-19-2019 est corrigée :
  http://ftp.sas.com/techsup/download/hotfix/HF2/SAS_Security_Updates.html
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilité de logiciel. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.