L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de json-c : corruption de mémoire

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire de json-c, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Debian, WebSphere MQ, Solaris, pfSense, Ubuntu.
Gravité de ce bulletin : 2/4.
Date de création : 15/05/2020.
Références de cette menace : 6382922, CVE-2020-12762, DLA-2228-1, DLA-2228-2, DLA-2301-1, DSA-4741-1, USN-4360-1, USN-4360-2, USN-4360-3, USN-4360-4, VIGILANCE-VUL-32277.

Description de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire de json-c, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Debian, WebSphere MQ, Solaris, pfSense, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace 

Debian 10 : nouveaux paquetages json-c.
De nouveaux paquetages sont disponibles :
  Debian 10 : json-c 0.12.1+ds-2+deb10u

Debian 8 : nouveaux paquetages json-c.
De nouveaux paquetages sont disponibles :
  Debian 8 : json-c 0.11-4+deb8u2

Debian 9 : nouveaux paquetages json-c.
De nouveaux paquetages sont disponibles :
  Debian 9 : json-c 0.12.1-1.1+deb9u1

IBM MQ : versions corrigées pour json-c.
Les versions corrigées sont indiquées dans les sources d'information.

Oracle Solaris : patch pour logiciels tiers de juillet 2020 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

pfSense : version 2.4.5-p1.
La version 2.4.5-p1 est corrigée :
  https://www.pfsense.org/download/
  https://www.netgate.com/

Ubuntu : nouveaux paquetages json-c.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : libjson-c4 0.13.1+dfsg-7ubuntu0.3
  Ubuntu 19.10 : libjson-c4 0.13.1+dfsg-4ubuntu0.3
  Ubuntu 18.04 LTS : libjson-c3 0.12.1-1.3ubuntu0.3
  Ubuntu 16.04 LTS : libjson-c2 0.11-4ubuntu2.6, libjson0 0.11-4ubuntu2.6
  Ubuntu 14.04 ESM : libjson-c2 0.11-3ubuntu1.2+esm3, libjson0 0.11-3ubuntu1.2+esm3
  Ubuntu 12.04 ESM : libjson0 0.9-1ubuntu1.4

Wind River Linux : version 10.18.44.17.
La version 10.18.44.17 est corrigée :
  https://support2.windriver.com/

Wind River Linux : version 10.19.45.8.
La version 10.19.45.8 est corrigée.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des bulletins de vulnérabilité applicative. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.