L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libcurl : redémarrage de session TLS malgré un changement de certificat

Synthèse de la vulnérabilité 

Le client TLS de libcurl peut réutiliser une session malgré le changement de certificat client, ce qui peut conduire à l'authentification sur un serveur avec l'identité incorrecte.
Produits vulnérables : SDS, SES, SNS, OpenOffice, Mac OS X, curl, pfSense, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 19/04/2017.
Références de ce bulletin : APPLE-SA-2017-07-19-2, CVE-2017-7468, HT207922, STORM-2019-002, USN-3262-1, VIGILANCE-VUL-22500.

Description de la vulnérabilité 

Le client TLS de libcurl peut réutiliser une session malgré le changement de certificat client, ce qui peut conduire à l'authentification sur un serveur avec une identité incorrecte.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de menace concerne les logiciels ou systèmes comme SDS, SES, SNS, OpenOffice, Mac OS X, curl, pfSense, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de vulnérabilité.

Solutions pour cette menace 

curl : version 7.54.0.
La version 7.54.0 est corrigée :
  https://curl.haxx.se/

curl : patch pour TLS Session Resume.
Un patch est indiqué dans les sources d'information.

Apache OpenOffice : version 4.1.6.
La version 4.1.6 est corrigée :
  https://www.openoffice.org/download/

Apple macOS : version 10.12.6.
La version 10.12.6 est corrigée :
  https://www.apple.com/

pfSense : version 2.3.4.
La version 2.3.4 est corrigée :
  https://www.pfsense.org/

Stormshield : solution pour curl.
La solution est indiquée dans les sources d'information.

Ubuntu : nouveaux paquetages curl.
De nouveaux paquetages sont disponibles :
  Ubuntu 17.04 : curl 7.52.1-4ubuntu1.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif cyber-sécurité. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.