L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libexif : débordement d'entier via exif-data.c

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un débordement d'entier via exif-data.c de libexif, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels vulnérables : Debian, Fedora, Android OS, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 07/02/2020.
Références de cette vulnérabilité informatique : CVE-2019-9278, DLA-2100-1, DSA-4618-1, FEDORA-2020-085150ac6e, FEDORA-2020-b4db792558, openSUSE-SU-2020:0264-1, openSUSE-SU-2020:0793-1, RHSA-2020:4040-01, RHSA-2020:4766-01, SSA:2020-140-02, SUSE-SU-2020:0457-1, SUSE-SU-2020:0458-1, SUSE-SU-2020:14294-1, SUSE-SU-2020:1534-1, SUSE-SU-2020:1553-2, USN-4277-1, VIGILANCE-VUL-31543.

Description de la vulnérabilité 

Un attaquant peut provoquer un débordement d'entier via exif-data.c de libexif, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Debian, Fedora, Android OS, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Debian 8 : libexif 0.6.21-2+deb8u1

Debian 9/10 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Debian 9 : libexif 0.6.21-2+deb9u1
  Debian 10 : libexif 0.6.21-5.1+deb10u1

Fedora 31 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Fedora 31 : libexif 0.6.22-1.fc31

Fedora 32 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Fedora 32 : libexif 0.6.22-1.fc32

Google Android OS : version Q 2019-09-01.
La version Q 2019-09-01 est corrigée :
  https://support.google.com/pixelphone/answer/4457705

openSUSE Leap 15.1 : nouveaux paquetages libexif (02/03/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libexif 0.6.21-lp151.4.3.1

openSUSE Leap 15.1 : nouveaux paquetages libexif (11/06/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libexif 0.6.22-lp151.4.6.1

Oracle Solaris : patch pour logiciels tiers de avril 2020 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.8 : nouveaux paquetages libexif (30/09/2020).
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : libexif 0.6.22-1.el7

RHEL 8 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  RHEL 8.0-8.2 : libexif 0.6.22-4.el8

Slackware : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : libexif 0.6.22-*-1_slack14.0
  Slackware 14.1 : libexif 0.6.22-*-1_slack14.1
  Slackware 14.2 : libexif 0.6.22-*-1_slack14.2

SUSE LE 11 SP3/4 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : libexif 0.6.17-2.14.7.2
  SUSE LE 11 SP4 : libexif 0.6.17-2.14.7.2

SUSE LE 12 : nouveaux paquetages libexif (04/06/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : libexif 0.6.22-8.9.1
  SUSE LE 12 SP2 : libexif 0.6.22-8.9.1
  SUSE LE 12 SP3 : libexif 0.6.22-8.9.1
  SUSE LE 12 SP4 : libexif 0.6.22-8.9.1
  SUSE LE 12 SP5 : libexif 0.6.22-8.9.1

SUSE LE 12 : nouveaux paquetages libexif (25/02/2020).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : libexif 0.6.21-8.6.1
  SUSE LE 12 SP2 : libexif 0.6.21-8.6.1
  SUSE LE 12 SP3 : libexif 0.6.21-8.6.1
  SUSE LE 12 SP4 : libexif 0.6.21-8.6.1
  SUSE LE 12 SP5 : libexif 0.6.21-8.6.1

SUSE LE 15 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : libexif 0.6.21-5.3.1
  SUSE LE 15 SP1 : libexif 0.6.21-5.3.1

SUSE LE 15 SP1-2 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : libexif 0.6.22-5.6.1
  SUSE LE 15 SP2 : libexif 0.6.22-5.6.1

Ubuntu : nouveaux paquetages libexif12.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : libexif12 0.6.21-5.1ubuntu0.1
  Ubuntu 18.04 LTS : libexif12 0.6.21-4ubuntu0.1
  Ubuntu 16.04 LTS : libexif12 0.6.21-2ubuntu0.1
  Ubuntu 14.04 ESM : libexif12 0.6.21-1ubuntu1+esm1
  Ubuntu 12.04 ESM : libexif12 0.6.20-2ubuntu0.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin cyber-sécurité. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.