L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libexif : lecture de mémoire hors plage prévue via exif_data_save_data_entry

Synthèse de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via exif_data_save_data_entry() de libexif, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Systèmes vulnérables : Debian, Solaris, Slackware, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 24/08/2018.
Références de cette faille : bulletinjul2018, CVE-2017-7544, DLA-2214-1, SSA:2020-140-02, USN-4277-1, VIGILANCE-VUL-27074.

Description de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via exif_data_save_data_entry() de libexif, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de faille concerne les logiciels ou systèmes comme Debian, Solaris, Slackware, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de faille.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Debian 8 : libexif 0.6.21-2+deb8u2

Oracle Solaris : patch pour logiciels tiers de juillet 2018 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Slackware : nouveaux paquetages libexif.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : libexif 0.6.22-*-1_slack14.0
  Slackware 14.1 : libexif 0.6.22-*-1_slack14.1
  Slackware 14.2 : libexif 0.6.22-*-1_slack14.2

Ubuntu : nouveaux paquetages libexif12.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : libexif12 0.6.21-5.1ubuntu0.1
  Ubuntu 18.04 LTS : libexif12 0.6.21-4ubuntu0.1
  Ubuntu 16.04 LTS : libexif12 0.6.21-2ubuntu0.1
  Ubuntu 14.04 ESM : libexif12 0.6.21-1ubuntu1+esm1
  Ubuntu 12.04 ESM : libexif12 0.6.20-2ubuntu0.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilités applicatives. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.