L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

avis sécurité CVE-2019-15903

libexpat : lecture de mémoire hors plage prévue via XML_GetCurrentLineNumber

Synthèse de la vulnérabilité

Un attaquant peut forcer la lecture à une adresse invalide via XML_GetCurrentLineNumber() de libexpat, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Gravité de cette vulnérabilité informatique : 2/4.
Date création : 09/09/2019.
Références de cette annonce : CERTFR-2019-AVI-535, CVE-2019-15903, DLA-1912-1, DLA-1987-1, DSA-4530-1, DSA-4549-1, FEDORA-2019-672ae0f060, FEDORA-2019-9505c6b555, FEDORA-2019-9b4ebc2973, MFSA-2019-33, MFSA-2019-34, MFSA-2019-35, openSUSE-SU-2019:2204-1, openSUSE-SU-2019:2205-1, openSUSE-SU-2019:2420-1, openSUSE-SU-2019:2424-1, openSUSE-SU-2019:2425-1, openSUSE-SU-2019:2447-1, openSUSE-SU-2019:2451-1, openSUSE-SU-2019:2452-1, openSUSE-SU-2019:2459-1, openSUSE-SU-2019:2464-1, RHSA-2019:3210-01, RHSA-2019:3237-01, RHSA-2019:3756-01, SSA:2019-259-01, SSA:2019-293-01, SSA:2019-295-01, SUSE-SU-2019:2429-1, SUSE-SU-2019:2440-1, SUSE-SU-2019:2871-1, SUSE-SU-2019:2872-1, SUSE-SU-2019:2912-1, USN-4132-1, USN-4132-2, USN-4165-1, USN-4165-2, VIGILANCE-VUL-30268.
Bulletin Vigil@nce complet... (Essai gratuit)

Description de la vulnérabilité

Un attaquant peut forcer la lecture à une adresse invalide via XML_GetCurrentLineNumber() de libexpat, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin Vigil@nce complet... (Essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Debian, Fedora, Firefox, Thunderbird, OpenBSD, openSUSE Leap, Python, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace

Debian 10 : nouveaux paquetages firefox-esr.
De nouveaux paquetages sont disponibles :
  Debian 10 : firefox-esr 68.2.0esr-1~deb10u1

Debian 8 : nouveaux paquetages firefox-esr.
De nouveaux paquetages sont disponibles :
  Debian 8 : firefox-esr 68.2.0esr-1~deb8u1

Debian : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  Debian 8 : expat 2.1.0-6+deb8u6
  Debian 9 : expat 2.2.0-2+deb9u3
  Debian 10 : expat 2.2.6-2+deb10u1

Fedora 31 : nouveaux paquetages thunderbird.
De nouveaux paquetages sont disponibles :
  Fedora 31 : thunderbird 68.2.0-1.fc31

Fedora : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  Fedora 29 : expat 2.2.8-1.fc29
  Fedora 30 : expat 2.2.8-1.fc30

Firefox : version 68.2.
La version 68.2 est corrigée :
  https://www.mozilla.org/en-US/firefox/

Firefox : version 70.
La version 70 est corrigée :
  https://www.mozilla.org/en-US/firefox/

OpenBSD : patch pour expat.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : chromium 78.0.3904.70-lp150.248.2
  openSUSE Leap 15.1 : chromium 78.0.3904.70-lp151.2.39.1
  SUSE LE 15 RTM : chromium 78.0.3904.70-bp150.240.1
  SUSE LE 15 SP1 : chromium 78.0.3904.70-bp151.3.21.1

openSUSE Leap 15 : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : expat 2.2.5-lp150.2.6.1
  openSUSE Leap 15.1 : expat 2.2.5-lp151.3.6.1

openSUSE Leap 15 : nouveaux paquetages MozillaFirefox.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : MozillaFirefox 68.2.0-lp150.3.71.1
  openSUSE Leap 15.1 : MozillaFirefox 68.2.0-lp151.2.18.2

openSUSE Leap 15 : nouveaux paquetages MozillaThunderbird.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : MozillaThunderbird 68.2.1-lp150.3.54.1
  openSUSE Leap 15.1 : MozillaThunderbird 68.2.1-lp151.2.16.1

Python : version 3.5.8.
La version 3.5.8 est corrigée :
  https://www.python.org/downloads/

RHEL 6 : nouveaux paquetages thunderbird.
De nouveaux paquetages sont disponibles :
  RHEL 6 : thunderbird 68.2.0-2.el6_10

RHEL 7 : nouveaux paquetages thunderbird.
De nouveaux paquetages sont disponibles :
  RHEL 7 : thunderbird 68.2.0-1.el7_7

RHEL 8 : nouveaux paquetages thunderbird.
De nouveaux paquetages sont disponibles :
  RHEL 8 : thunderbird 68.2.0-1.el8_0

Slackware 14 : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : expat 2.2.8-*-1_slack14.0
  Slackware 14.1 : expat 2.2.8-*-1_slack14.1
  Slackware 14.2 : expat 2.2.8-*-1_slack14.2

Slackware : nouveaux paquetages mozilla-firefox.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : mozilla-firefox 68.2.0esr-*-1_slack14.2

Slackware : nouveaux paquetages python.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : python 2.7.17-*-1_slack14.0
  Slackware 14.1 : python 2.7.17-*-1_slack14.1
  Slackware 14.2 : python 2.7.17-*-1_slack14.2

SUSE LE 12 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : chromium 78.0.3904.87-10.1

SUSE LE 12 : nouveaux paquetages MozillaFirefox (31/10/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : MozillaFirefox 68.2.0-109.95.2
  SUSE LE 12 SP2 : MozillaFirefox 68.2.0-109.95.2
  SUSE LE 12 SP3 : MozillaFirefox 68.2.0-109.95.2
  SUSE LE 12 SP4 : MozillaFirefox 68.2.0-109.95.2
  SUSE LE 12 SP5 : MozillaFirefox 68.2.0-109.95.2

SUSE LE 15 : nouveaux paquetages MozillaFirefox.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : MozillaFirefox 68.2.0-3.59.1
  SUSE LE 15 SP1 : MozillaFirefox 68.2.0-3.59.1

SUSE LE 15 : nouveaux paquetages MozillaThunderbird.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : MozillaThunderbird 68.2.1-3.58.1
  SUSE LE 15 SP1 : MozillaThunderbird 68.2.1-3.58.1

SUSE LE : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : expat 2.2.5-3.6.1
  SUSE LE 15 RTM : expat 2.2.5-3.6.1
  SUSE LE 12 SP4 : expat 2.1.0-21.9.1

Thunderbird : version 68.2.
La version 68.2 est corrigée :
  https://www.mozilla.org/

Ubuntu : nouveaux paquetages firefox.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : firefox 70.0.1+build1-0ubuntu0.19.10.1
  Ubuntu 19.04 : firefox 70.0.1+build1-0ubuntu0.19.04.1
  Ubuntu 18.04 LTS : firefox 70.0.1+build1-0ubuntu0.18.04.1
  Ubuntu 16.04 LTS : firefox 70.0.1+build1-0ubuntu0.16.04.1

Ubuntu : nouveaux paquetages libexpat1.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : libexpat1 2.2.6-1ubuntu0.19.5
  Ubuntu 18.04 LTS : libexpat1 2.2.5-3ubuntu0.2
  Ubuntu 16.04 LTS : libexpat1 2.1.0-7ubuntu0.16.04.5
  Ubuntu 14.04 ESM : libexpat1 2.1.0-4ubuntu1.4+esm2
  Ubuntu 12.04 ESM: libexpat1 2.0.1-7.2ubuntu1.7
Bulletin Vigil@nce complet... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit un bulletin cybersécurité. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.