L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libgd : buffer overflow via dynamicGetbuf

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via dynamicGetbuf de libgd, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes impactés : Mac OS X, Debian, Fedora, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 19/10/2016.
Références de cette alerte : CVE-2016-8670, DLA-665-1, FEDORA-2016-722c0afc64, FEDORA-2016-e45a7e7b13, HT207483, openSUSE-SU-2016:2606-1, openSUSE-SU-2016:2772-1, openSUSE-SU-2016:2831-1, openSUSE-SU-2016:2837-1, SUSE-SU-2016:2460-2, SUSE-SU-2016:2668-1, SUSE-SU-2016:2683-1, SUSE-SU-2016:2683-2, SUSE-SU-2016:2766-1, USN-3117-1, VIGILANCE-VUL-20915.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via dynamicGetbuf de libgd, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin sécurité concerne les logiciels ou systèmes comme Mac OS X, Debian, Fedora, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de menace informatique.

Solutions pour cette menace 

Apple macOS : version 10.12.3.
La version 10.12.3 est corrigée :
  https://support.apple.com/

Debian 7 : nouveaux paquetages libgd2.
De nouveaux paquetages sont disponibles :
  Debian 7 : libgd2 2.0.36~rc1~dfsg-6.1+deb7u6

Fedora : nouveaux paquetages gd.
De nouveaux paquetages sont disponibles :
  Fedora 25 : gd 2.2.3-5.fc25
  Fedora 24 : gd 2.2.3-5.fc24

openSUSE 13.2 : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : apache2-mod_php5 5.6.1-83.1, php5 5.6.1-83.1

openSUSE Leap 42.1 : nouveaux paquetages gd.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : gd 2.1.0-13.1

openSUSE Leap : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : apache2-mod_php5 5.5.14-65.2, php5 5.5.14-65.2
  openSUSE Leap 42.2 : apache2-mod_php5 5.5.14-65.1, php5 5.5.14-65.1

SUSE LE 12 : nouveaux paquetages gd.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : gd 2.1.0-17.1

SUSE LE 12 : nouveaux paquetages php5.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP2 : apache2-mod_php5 5.5.14-83.1, php5 5.5.14-83.1

SUSE LE 12 SP2 : nouveaux paquetages php7.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : apache2-mod_php7 7.0.7-20.1, php7 7.0.7-20.1

Ubuntu : nouveaux paquetages libgd3.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.10 : libgd3 2.2.1-1ubuntu3.2
  Ubuntu 16.04 LTS : libgd3 2.1.1-4ubuntu0.16.04.5
  Ubuntu 14.04 LTS : libgd3 2.1.0-3ubuntu0.5
  Ubuntu 12.04 LTS : libgd2 2.0.36~rc1~dfsg-6ubuntu2.3
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une base de vulnérabilités de systèmes. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.