L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libmspack : corruption de mémoire via kwajd_read_headers

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via kwajd_read_headers() de libmspack, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits vulnérables : ClamAV, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 02/08/2018.
Références de ce bulletin : CVE-2018-14681, DLA-1460-1, DSA-4260-1, FEDORA-2018-a5953af115, FEDORA-2018-c73d257297, FEDORA-2018-cb337fb199, openSUSE-SU-2018:3315-1, openSUSE-SU-2018:3505-1, RHSA-2018:3327-01, SUSE-SU-2018:3250-1, SUSE-SU-2018:3436-1, SUSE-SU-2018:3441-1, USN-3728-1, USN-3728-2, USN-3728-3, USN-3789-2, VIGILANCE-VUL-26892.

Description de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via kwajd_read_headers() de libmspack, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité concerne les logiciels ou systèmes comme ClamAV, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cyber-sécurité.

Solutions pour cette menace 

ClamAV : version 0.100.2.
La version 0.100.2 est corrigée :
  https://www.clamav.net/

Debian 8 : nouveaux paquetages libmspack.
De nouveaux paquetages sont disponibles :
  Debian 8 : libmspack 0.5-1+deb8u2

Debian 9 : nouveaux paquetages libmspack.
De nouveaux paquetages sont disponibles :
  Debian 9 : libmspack 0.5-1+deb9u2

Fedora : nouveaux paquetages cabextract.
De nouveaux paquetages sont disponibles :
  Fedora 27 : cabextract 1.9-1.fc27
  Fedora 28 : cabextract 1.9-1.fc28
  Fedora 29 : cabextract 1.9-1.fc29

Fedora : nouveaux paquetages libmspack.
De nouveaux paquetages sont disponibles :
  Fedora 27 : libmspack 0.9.1-0.1.alpha.fc27
  Fedora 28 : libmspack 0.9.1-0.1.alpha.fc28
  Fedora 29 : libmspack 0.9.1-0.1.alpha.fc29

openSUSE Leap 15.0 : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : clamav 0.100.2-lp150.2.6.1

openSUSE Leap 42.3 : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : clamav 0.100.2-32.1

RHEL 7 : nouveaux paquetages libmspack.
De nouveaux paquetages sont disponibles :
  RHEL 7 : libmspack 0.5-0.6.alpha.el7

SUSE LE 11 : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : clamav 0.100.2-0.20.18.1
  SUSE LE 11 SP4 : clamav 0.100.2-0.20.18.1

SUSE LE 12 : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : clamav 0.100.2-33.18.1
  SUSE LE 12 SP1 : clamav 0.100.2-33.18.1
  SUSE LE 12 SP2 : clamav 0.100.2-33.18.1
  SUSE LE 12 SP3 : clamav 0.100.2-33.18.1

SUSE LE 15 : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : clamav 0.100.2-3.6.4

Ubuntu 12.04 : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 ESM : clamav 0.100.2+dfsg-1ubuntu0.12.04.1

Ubuntu : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : clamav 0.100.1+dfsg-1ubuntu0.14.04.3
  Ubuntu 12.04 ESM : clamav 0.100.1+dfsg-1ubuntu0.12.04.3

Ubuntu : nouveaux paquetages libmspack.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : libmspack0 0.6-3ubuntu0.1
  Ubuntu 16.04 LTS : libmspack0 0.5-1ubuntu0.16.04.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une contre-mesure de vulnérabilité de logiciel. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.