L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libslirp : buffer overflow via ip_reass

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via ip_reass() de libslirp, afin de mener un déni de service, et éventuellement d'exécuter du code.
Logiciels impactés : Debian, Fedora, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (plateforme) ~ non exhaustif.
Gravité de cette vulnérabilité informatique : 3/4.
Date de création : 01/08/2019.
Références de cette annonce : CVE-2019-14378, DLA-1927-1, DSA-4506-1, DSA-4512-1, FEDORA-2019-77bafc4454, openSUSE-SU-2019:2041-1, openSUSE-SU-2019:2059-1, openSUSE-SU-2019:2510-1, RHSA-2019:3403-01, RHSA-2019:3494-01, RHSA-2019:3968-01, RHSA-2020:0366-01, RHSA-2020:0775-01, RHSA-2020:0889-01, RHSA-2020:2065-01, RHSA-2020:2126-01, SUSE-SU-2019:14151-1, SUSE-SU-2019:2157-1, SUSE-SU-2019:2192-1, SUSE-SU-2019:2221-1, SUSE-SU-2019:2246-1, SUSE-SU-2019:2353-1, SUSE-SU-2019:2783-1, SUSE-SU-2019:2955-1, SUSE-SU-2020:0388-1, USN-4191-1, USN-4191-2, VIGILANCE-VUL-29926.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via ip_reass() de libslirp, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (plateforme) ~ non exhaustif.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

libslirp : patch pour ip_reass.
Un patch est indiqué dans les sources d'information.

Debian 10 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Debian 10 : qemu 1:3.1+dfsg-8+deb10u2

Debian 8 : nouveaux paquetages qemu (doublon).
Ce bulletin est un doublon de VIGILANCE-SOL-68382.

Debian 8 : nouveaux paquetages qemu (original).
De nouveaux paquetages sont disponibles :
  Debian 8 : qemu 1:2.1+dfsg-12+deb8u12

Debian 9 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Debian 9 : qemu 1:2.8+dfsg-6+deb9u8

Fedora 30 : nouveaux paquetages libslirp.
De nouveaux paquetages sont disponibles :
  Fedora 30 : libslirp 4.0.0-2.fc30

openSUSE Leap 15.0 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : qemu 2.11.2-lp150.7.25.1

openSUSE Leap 15.1 : nouveaux paquetages qemu (02/09/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : qemu 3.1.1-lp151.7.3.3

openSUSE Leap 15.1 : nouveaux paquetages qemu (14/11/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : qemu 3.1.1.1-lp151.7.6.1

QEMU : patch pour slirp.
Un patch est indiqué dans les sources d'information.

QEMU : version 4.0.1.
La version 4.0.1 est corrigée :
  https://www.qemu.org/download/#source

RHEL 6.10 : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 6.10 : qemu-kvm 0.12.1.2-2.506.el6_10.6

RHEL 7.6 : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 7.6 : qemu-kvm 1.5.3-160.el7_6.6

RHEL 7.7 : nouveaux paquetages qemu-kvm.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : qemu-kvm 1.5.3-167.el7_7.4

RHEL 7 : nouveaux paquetages qemu-kvm-ma.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : qemu-kvm-ma 2.12.0-33.el7_7.1
  RHEL 7.6 : qemu-kvm-ma 2.12.0-18.el7_6.6

RHEL 7 : nouveaux paquetages slirp4netns.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : slirp4netns 0.3.0-8.el7_7

RHEL 8 : nouveau module container-tools-1.0.
Le module suivant est mis à jour :
  RHEL 8 Module : container-tools:1.0

RHEL 8 : nouveau module container-tools-rhel8.
Le module suivant est mis à jour :
  RHEL 8 Module : container-tools:rhel8

SUSE LE 11 SP4 : nouveaux paquetages kvm.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : kvm 1.4.2-60.27.1

SUSE LE 12 SP1 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : qemu 2.3.1-33.26.1

SUSE LE 12 SP1 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : xen 4.5.5_28-22.64.1

SUSE LE 12 SP2 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : qemu 2.6.2-41.55.1

SUSE LE 12 SP2 : nouveaux paquetages xen.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : xen 4.7.6_06-43.54.2

SUSE LE 12 SP4 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : qemu 2.11.2-5.18.1

SUSE LE 15 : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : qemu 2.11.2-9.28.3

SUSE LE 15 SP1 : nouveaux paquetages qemu (13/11/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : qemu 3.1.1.1-9.6.2

SUSE LE 15 SP1 : nouveaux paquetages qemu (22/08/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : qemu 3.1.1-9.3.3

Ubuntu : nouveaux paquetages qemu.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : qemu 1:4.0+dfsg-0ubuntu9.1
  Ubuntu 19.04 : qemu 1:3.1+dfsg-2ubuntu3.6
  Ubuntu 18.04 LTS : qemu 1:2.11+dfsg-1ubuntu7.20
  Ubuntu 16.04 LTS : qemu 1:2.5+dfsg-5ubuntu10.42
  Ubuntu 14.04 ESM : qemu 2.0.0+dfsg-2ubuntu1.47
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilité de réseau. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.