L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libsndfile : buffer overflow via i2alaw/i2ulaw_array

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via i2alaw/i2ulaw_array() de libsndfile, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes vulnérables : Debian, RHEL, Ubuntu.
Gravité de cette menace : 3/4.
Nombre de vulnérabilités dans ce bulletin : 2.
Date de création : 30/11/2018.
Références de cette faille : 429, CVE-2018-19661, CVE-2018-19662, DLA-1618-1, RHSA-2020:1636-01, RHSA-2020:3922-01, USN-4013-1, VIGILANCE-VUL-27926.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via i2alaw/i2ulaw_array() de libsndfile, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité concerne les logiciels ou systèmes comme Debian, RHEL, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cyber-sécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Ce bulletin concerne 2 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce cybersécurité.

Solutions pour cette menace 

libsndfile : patch pour i2alaw/i2ulaw_array.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages libsndfile.
De nouveaux paquetages sont disponibles :
  Debian 8 : libsndfile 1.0.25-9.1+deb8u2

RHEL 7.8 : nouveaux paquetages libsndfile.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : libsndfile 1.0.25-12.el7

RHEL 8 : nouveaux paquetages libsndfile.
De nouveaux paquetages sont disponibles :
  RHEL 8.0-8.1 : libsndfile 1.0.28-10.el8

Ubuntu : nouveaux paquetages libsndfile1.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : libsndfile1 1.0.28-4ubuntu0.18.10.1
  Ubuntu 18.04 LTS : libsndfile1 1.0.28-4ubuntu0.18.04.1
  Ubuntu 16.04 LTS : libsndfile1 1.0.25-10ubuntu0.16.04.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilité de logiciel. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.