L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libssh : exécution de code via ssh_scp_new

Synthèse de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via ssh_scp_new() de libssh, afin d'exécuter du code.
Produits vulnérables : Debian, Fedora, MySQL Community, MySQL Enterprise, openSUSE Leap, Percona Server, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 11/12/2019.
Références de ce bulletin : cpuapr2020, CVE-2019-14889, DLA-2038-1, DLA-2038-2, FEDORA-2019-46b6bd2459, FEDORA-2019-8b0ad69829, openSUSE-SU-2019:2689-1, openSUSE-SU-2020:0102-1, RHSA-2020:4545-01, SUSE-SU-2019:3267-1, SUSE-SU-2019:3293-1, SUSE-SU-2019:3307-1, SUSE-SU-2019:3308-1, SUSE-SU-2020:0129-1, SUSE-SU-2020:0130-1, SUSE-SU-2020:0131-1, SUSE-SU-2020:0139-1, USN-4219-1, VIGILANCE-VUL-31116.

Description de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via ssh_scp_new() de libssh, afin d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, Fedora, MySQL Community, MySQL Enterprise, openSUSE Leap, Percona Server, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de menace.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  Debian 8 : libssh 0.6.3-4+deb8u4

Fedora : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  Fedora 30 : libssh 0.9.3-1.fc30
  Fedora 31 : libssh 0.9.3-1.fc31

openSUSE Leap 15.1 : nouveaux paquetages libssh (17/12/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libssh 0.8.7-lp151.2.6.1

openSUSE Leap 15.1 : nouveaux paquetages libssh (27/01/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libssh 0.8.7-lp151.2.9.1

Oracle MySQL : version 5.6.48.
La version 5.6.48 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 5.7.30.
La version 5.7.30 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL : version 8.0.20.
La version 8.0.20 est corrigée :
  https://support.oracle.com/rs?type=doc&id=2648128.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Percona Server : version 5.6.48-88.0.
La version 5.6.48-88.0 est corrigée.

RHEL 8 : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  RHEL 8.0-8.2 : libssh 0.9.4-2.el8

SUSE LE 12 SP4 : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : libssh 0.6.3-12.9.1

SUSE LE 12 SP5 : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : libssh 0.8.7-3.3.1

SUSE LE 15 RTM : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : libssh 0.7.5-6.6.1

SUSE LE 15 SP1 : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : libssh 0.8.7-10.6.2

SUSE LE : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : libssh 0.6.3-12.12.1
  SUSE LE 12 SP5 : libssh 0.8.7-3.6.1
  SUSE LE 15 RTM : libssh 0.7.5-6.9.2
  SUSE LE 15 SP1 : libssh 0.8.7-10.9.1

Ubuntu : nouveaux paquetages libssh.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : libssh-4 0.9.0-1ubuntu1.3
  Ubuntu 19.04 : libssh-4 0.8.6-3ubuntu0.3
  Ubuntu 18.04 LTS : libssh-4 0.8.0~20170825.94fa1e38-1ubuntu0.5
  Ubuntu 16.04 LTS : libssh-4 0.6.3-4.3ubuntu0.5
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilité de réseau. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.