L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libxslt : lecture/écriture via xsltCheckRead/xsltCheckWrite

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via xsltCheckRead/xsltCheckWrite() de libxslt, afin d'obtenir des informations sensibles, ou de modifier des données.
Produits vulnérables : Debian, Unisphere EMC, Fedora, SnapManager, openSUSE Leap, Java Oracle, Solaris, Puppet, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 3/4.
Date création : 16/04/2019.
Références de ce bulletin : bulletinoct2019, cpuoct2019, CVE-2019-11068, DLA-1756-1, DSA-2019-168, DSA-2019-169, DSA-2019-186, FEDORA-2019-320d5295fc, FEDORA-2019-e21c77ffae, FEDORA-2019-e74d639587, NTAP-20191017-0001, openSUSE-SU-2019:1428-1, openSUSE-SU-2019:1430-1, openSUSE-SU-2019:1433-1, openSUSE-SU-2019:1527-1, openSUSE-SU-2019:1824-1, SUSE-SU-2019:1221-2, SUSE-SU-2019:1232-1, SUSE-SU-2019:1381-1, SUSE-SU-2019:1973-1, USN-3947-1, USN-3947-2, VIGILANCE-VUL-29040.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via xsltCheckRead/xsltCheckWrite() de libxslt, afin d'obtenir des informations sensibles, ou de modifier des données.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis sécurité concerne les logiciels ou systèmes comme Debian, Unisphere EMC, Fedora, SnapManager, openSUSE Leap, Java Oracle, Solaris, Puppet, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte sécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité.

Solutions pour cette menace 

Cloud Foundry BOSH : versions corrigées pour libxslt.
Les versions corrigées sont indiquées dans les sources d'information.

Debian 8 : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  Debian 8 : libxslt 1.1.28-2+deb8u4

EMC Unisphere for PowerMax : versions 9.0.2.16 et 9.1.0.9.
Les versions 9.0.2.16 et 9.1.0.9 sont corrigées :
  https://www.dell.com/support/home/us/en/19/product-support/product/unisphere-powermax/drivers

Fedora 30 : nouveaux paquetages mingw-libxslt.
De nouveaux paquetages sont disponibles :
  Fedora 30 : mingw-libxslt 1.1.33-1.fc30

Fedora : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  Fedora 29 : libxslt 1.1.33-1.fc29
  Fedora 30 : libxslt 1.1.33-1.fc30

openSUSE Leap 15.0 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : rmt-server 2.1.4-lp150.2.16.1

openSUSE Leap 15.1 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : rmt-server 2.3.1-lp151.2.3.1

openSUSE Leap : nouveaux paquetages libxslt1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : libxslt1 1.1.28-13.3.1
  openSUSE Leap 15.1 : libxslt1 1.1.32-lp151.3.3.1
  openSUSE Leap 15.0 : libxslt1 1.1.32-lp150.2.3.1

Oracle Java : version 11.0.5.
La version 11.0.5 est corrigée :
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/technetwork/java/javase/11u-relnotes-5093844.html

Oracle Java : version 13.0.1.
La version 13.0.1 est corrigée :
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/technetwork/java/javase/13u-relnotes-5461742.html

Oracle Java : version 7u241.
La version 7u241 est corrigée :
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/javase7supportreleasenotes-1601161.html

Oracle Java : version 8u231.
La version 8u231 est corrigée :
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/8u-relnotes-2225394.html

Oracle Solaris : patch pour logiciels tiers de octobre 2019 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Puppet Enterprise : versions 2019.0.3 et 2018.1.8.
Les versions 2019.0.3 et 2018.1.8 sont corrigées.

RSA Authentication Manager : version 8.4 P8.
La version 8.4 P8 est corrigée :
  https://www.dell.com/

SnapManager : solution pour Java.
La solution est indiquée dans les sources d'information.

SUSE LE 12 SP3/4 : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : libxslt 1.1.28-17.3.1
  SUSE LE 12 SP4 : libxslt 1.1.28-17.3.1

SUSE LE 15 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : rmt-server 2.1.4-3.17.1

SUSE LE 15 SP1 : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : libxslt 1.1.32-3.3.1

SUSE LE 15 SP1 : nouveaux paquetages rmt-server.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : rmt-server 2.3.1-3.3.3

Ubuntu : nouveaux paquetages libxslt1.1.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : libxslt1.1 1.1.32-2ubuntu0.1
  Ubuntu 18.04 LTS : libxslt1.1 1.1.29-5ubuntu0.1
  Ubuntu 16.04 LTS : libxslt1.1 1.1.28-2.1ubuntu0.2
  Ubuntu 14.04 LTS : libxslt1.1 1.1.28-2ubuntu0.2
  Ubuntu 12.04 ESM : libxslt1.1 1.1.26-8ubuntu1.5

Wind River Linux : solution (21/05/2019).
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse cybersécurité. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.