L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de libxslt, navigateurs : obtention d'adresse mémoire

Synthèse de la vulnérabilité 

Un attaquant peut appeler la fonction XSLT XPath generate-id(), afin d'obtenir une adresse mémoire.
Logiciels vulnérables : Fedora, Mandriva Linux, IE, Firefox, SeaMonkey, Opera, Solaris, RHEL, Unix (plateforme) ~ non exhaustif, ESX.
Gravité de cette annonce : 1/4.
Nombre de vulnérabilités dans ce bulletin : 3.
Date de création : 10/03/2011.
Références de cette vulnérabilité informatique : BID-46818, BID-47668, CERTA-2013-AVI-145, CERTFR-2014-AVI-112, CVE-2011-1202, CVE-2011-1712, CVE-2011-1713, ESX410-201301001, ESX410-201301401-SG, ESX410-201301402-SG, ESX410-201301403-SG, ESX410-201301405-SG, FEDORA-2011-6245, FEDORA-2011-6258, FEDORA-2012-14048, FEDORA-2012-14083, MDVSA-2011:079, MDVSA-2012:164, RHSA-2012:1265-01, VIGILANCE-VUL-10441, VMSA-2013-0001, VMSA-2013-0003.

Description de la vulnérabilité 

La fonction XSLT XPath generate-id() génère un identifiant unique pour un nœud de données XML.

Selon les implémentations de XSLT (eXtensible Stylesheet Language Transformations), generate-id() utilise :
 - xsltGenerateIdFunction() dans la bibliothèque libxslt
 - txXPathNodeUtils::getXSLTId() dans Firefox
 - une fonction de msxml.dll dans Internet Explorer
 - une fonction spécifique dans Opera

Même si ces implémentations sont différentes, elles génèrent toutes un identifiant basé sur l'adresse mémoire du nœud.

Un attaquant peut donc appeler la fonction XSLT XPath generate-id(), afin d'obtenir une adresse mémoire. Cette vulnérabilité aide par exemple à contourner ASLR (Address Space Layout Randomization).
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce cybersécurité concerne les logiciels ou systèmes comme Fedora, Mandriva Linux, IE, Firefox, SeaMonkey, Opera, Solaris, RHEL, Unix (plateforme) ~ non exhaustif, ESX.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de menace est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Ce bulletin concerne 3 vulnérabilités.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette faille cyber-sécurité.

Solutions pour cette menace 

Firefox : version 4.0.1.
La version 4.0.1 est corrigée :
  http://www.mozilla-europe.org/fr/

Firefox : version 3.6.17.
La version 3.6.17 est corrigée :
  http://www.mozilla.com/en-US/firefox/all-older.html

Firefox : version 3.5.19.
La version 3.5.19 est corrigée :
  http://www.mozilla.com/en-US/firefox/all-older.html

SeaMonkey : version 2.0.14.
La version 2.0.14 est corrigée :
  http://www.seamonkey-project.org/releases/

libxslt : version 1.1.27.
La version 1.1.27 est corrigée :
  ftp://xmlsoft.org/libxslt/

libxslt : patch.
Un patch est disponible dans les sources d'information.

Fedora : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  libxslt-1.1.26-9.fc16
  libxslt-1.1.26-10.fc17

Fedora : nouveaux paquetages seamonkey.
De nouveaux paquetages sont disponibles :
  Fedora 14 : seamonkey-2.0.14-1.fc14
  Fedora 13 : seamonkey-2.0.14-1.fc13

Mandriva : nouveaux paquetages firefox.
De nouveaux paquetages sont disponibles :
  firefox-3.6.17-0.1mdv2009.0
  firefox-3.6.17-0.1mdv2010.0
  firefox-3.6.17-0.1mdv2010.2
  firefox-3.6.17-0.1mdvmes5.2

Mandriva : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  libxslt-1.1.26-4.3-mdv2011.0
  libxslt-1.1.24-3.3mdvmes5.2

RHEL : nouveaux paquetages libxslt.
De nouveaux paquetages sont disponibles :
  libxslt-1.1.17-4.el5_8.3
  libxslt-1.1.26-2.el6_3.1

Solaris 11 : version 11.1.4.5.
La version 11.1.4.5 est corrigée :
  https://support.oracle.com/rs?type=doc&id=1530204.1

Solaris 9, 10 : patch pour libxslt.
Un patch est disponible :
Solaris 9 :
  SPARC: 114014-32
  X86: 114015-32
Solaris 10 :
  SPARC: 125731-09
  X86: 125732-09

VMware ESX 4.1 : patch ESX410-201301001.
Un patch est disponible :
  http://kb.vmware.com/kb/2041331
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une contre-mesure de vulnérabilité applicative. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.