L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données et des outils pour y remédier.

Vulnérabilité de memcached : lecture de mémoire hors plage prévue via conn_to_str

Synthèse de la vulnérabilité

Un attaquant peut forcer la lecture à une adresse invalide via conn_to_str() de memcached, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Gravité de cette alerte : 2/4.
Date création : 09/09/2019.
Références de cette alerte : CVE-2019-15026, DLA-1913-1, FEDORA-2019-15d61c1f7f, FEDORA-2019-68333329e0, USN-4125-1, VIGILANCE-VUL-30269.

Description de la vulnérabilité

Un attaquant peut forcer la lecture à une adresse invalide via conn_to_str() de memcached, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin Vigil@nce complet... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Debian, Fedora, Solaris, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace

memcached : version 1.5.17.
La version 1.5.17 est corrigée :
  https://github.com/memcached/memcached/releases

memcached : patch pour conn_to_str.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages memcached.
De nouveaux paquetages sont disponibles :
  Debian 8 : memcached 1.4.21-1.1+deb8u3

Fedora : nouveaux paquetages memcached.
De nouveaux paquetages sont disponibles :
  Fedora 29 : memcached 1.5.14-2.fc29
  Fedora 30 : memcached 1.5.14-2.fc30

Oracle Solaris : patch pour logiciels tiers de octobre 2019 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Ubuntu : nouveaux paquetages memcached.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : memcached 1.5.10-0ubuntu1.19.04.2
  Ubuntu 18.04 LTS : memcached 1.5.6-0ubuntu1.2
  Ubuntu 16.04 LTS : memcached 1.4.25-2ubuntu1.5
Bulletin Vigil@nce complet... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit des avis de vulnérabilité de réseau. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.