L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de nghttp2 : déni de service via Large SETTINGS Frames

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via Large SETTINGS Frames de nghttp2, afin de mener un déni de service.
Produits vulnérables : Fedora, QRadar SIEM, openSUSE Leap, Oracle Communications, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette faille : 3/4.
Date de création : 25/06/2020.
Références de ce bulletin : 6409294, bulletinjul2020, cpujan2021, cpuoct2020, CVE-2020-11080, FEDORA-2020-f7d15c8b77, openSUSE-SU-2021:0468-1, RHSA-2020:2755-01, RHSA-2020:2784-01, RHSA-2020:2850-01, RHSA-2020:2895-01, RHSA-2020:3042-01, SUSE-SU-2021:0930-1, SUSE-SU-2021:0931-1, SUSE-SU-2021:0932-1, VIGILANCE-VUL-32622.

Description de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via Large SETTINGS Frames de nghttp2, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cyber-sécurité concerne les logiciels ou systèmes comme Fedora, QRadar SIEM, openSUSE Leap, Oracle Communications, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de vulnérabilité.

Solutions pour cette menace 

Fedora 31 : nouveaux paquetages nghttp2.
De nouveaux paquetages sont disponibles :
  Fedora 31 : nghttp2 1.41.0-1.fc31

IBM QRadar SIEM : versions corrigées pour IBM Security QRadar Analyst Workflow.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE Leap 15.2 : nouveaux paquetages nghttp2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : nghttp2 1.40.0-lp152.2.6.1

Oracle Communications : CPU de janvier 2021.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2737802.1
  https://support.oracle.com/rs?type=doc&id=2738918.1
  https://support.oracle.com/rs?type=doc&id=2738919.1
  https://support.oracle.com/rs?type=doc&id=2738920.1
  https://support.oracle.com/rs?type=doc&id=2738930.1
  https://support.oracle.com/rs?type=doc&id=2737803.1
  https://support.oracle.com/rs?type=doc&id=2737804.1
  https://support.oracle.com/rs?type=doc&id=2738931.1
  https://support.oracle.com/rs?type=doc&id=2738942.1
  https://support.oracle.com/rs?type=doc&id=2737809.1
  https://support.oracle.com/rs?type=doc&id=2737806.1
  https://support.oracle.com/rs?type=doc&id=2737808.1

Oracle Communications : CPU de octobre 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2714788.1
  https://support.oracle.com/rs?type=doc&id=2713777.1
  https://support.oracle.com/rs?type=doc&id=2714789.1
  https://support.oracle.com/rs?type=doc&id=2714787.1
  https://support.oracle.com/rs?type=doc&id=2714763.1
  https://support.oracle.com/rs?type=doc&id=2714792.1
  https://support.oracle.com/rs?type=doc&id=2713779.1
  https://support.oracle.com/rs?type=doc&id=2713303.1
  https://support.oracle.com/rs?type=doc&id=2714790.1
  https://support.oracle.com/rs?type=doc&id=2712893.1
  https://support.oracle.com/rs?type=doc&id=2714764.1
  https://support.oracle.com/rs?type=doc&id=2714796.1
  https://support.oracle.com/rs?type=doc&id=2714988.1
  https://support.oracle.com/rs?type=doc&id=2714791.1

Oracle Solaris : patch pour logiciels tiers de juillet 2020 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 6 : nouveaux paquetages httpd24-nghttp2.
De nouveaux paquetages sont disponibles :
  RHEL 6.0-6.10 : httpd24-nghttp2 1.7.1-8.el6.1

RHEL 7 : nouveaux paquetages rh-nodejs12-nodejs.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : rh-nodejs12-nodejs 12.18.2-1.el7

RHEL 8.0 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8.0 Module : nodejs:10

RHEL 8.0 : nouveaux paquetages nghttp2.
De nouveaux paquetages sont disponibles :
  RHEL 8.0 : nghttp2 1.33.0-1.el8_0.2

RHEL 8.2 : nouveaux paquetages nghttp2.
De nouveaux paquetages sont disponibles :
  RHEL 8.2 : nghttp2 1.33.0-3.el8_2.1

SUSE LE 12 SP2-5 : nouveaux paquetages nghttp2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : nghttp2 1.39.2-3.5.1
  SUSE LE 12 SP3 : nghttp2 1.39.2-3.5.1
  SUSE LE 12 SP4 : nghttp2 1.39.2-3.5.1
  SUSE LE 12 SP5 : nghttp2 1.39.2-3.5.1

SUSE LE 15 RTM-SP2 : nouveaux paquetages nghttp2.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : nghttp2 1.40.0-3.11.1
  SUSE LE 15 SP1 : nghttp2 1.40.0-3.11.1
  SUSE LE 15 SP2 : nghttp2 1.40.0-3.5.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilités logicielles. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.