L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de nginx : obtention d'information via error_page Request Smuggling

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via error_page Request Smuggling de nginx, afin d'obtenir des informations sensibles.
Systèmes impactés : IBM API Connect, nginx, openSUSE Leap, RHEL, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 10/01/2020.
Références de cette alerte : 6208032, 6208039, 6208048, 6208052, 6208328, 6208330, 6208332, 6208333, 6208336, CVE-2019-20372, openSUSE-SU-2020:0204-1, RHSA-2020:2817-01, SUSE-SU-2020:0348-1, SUSE-SU-2020:1171-1, USN-4235-1, USN-4235-2, VIGILANCE-VUL-31301.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via error_page Request Smuggling de nginx, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de faille informatique concerne les logiciels ou systèmes comme IBM API Connect, nginx, openSUSE Leap, RHEL, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter ce bulletin de faille informatique.

Solutions pour cette menace 

nginx : version 1.17.7.
La version 1.17.7 est corrigée :
  http://nginx.org/

IBM API Connect : version 2018.4.1.11.
La version 2018.4.1.11 est corrigée.

IBM API Connect : version 5.0.8.8.
La version 5.0.8.8 est corrigée.

openSUSE Leap 15.1 : nouveaux paquetages nginx.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : nginx 1.14.2-lp151.4.6.1

RHEL 7 : nouveaux paquetages rh-nginx116-nginx.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : rh-nginx116-nginx 1.16.1-4.el7.1

SUSE LE 15 : nouveaux paquetages nginx.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : nginx 1.14.2-6.7.1
  SUSE LE 15 RTM : nginx 1.16.1-3.12.7

Ubuntu : nouveaux paquetages nginx.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : nginx 1.16.1-0ubuntu2.1
  Ubuntu 19.04 : nginx 1.15.9-0ubuntu1.2
  Ubuntu 18.04 LTS : nginx 1.14.0-0ubuntu1.7
  Ubuntu 16.04 LTS : nginx 1.10.3-0ubuntu0.16.04.5
  Ubuntu 14.04 ESM : nginx 1.4.6-1ubuntu3.9+esm1

Wind River Linux : version 10.18.44.15.
La version 10.18.44.15 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilité informatique. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.