L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de phpMyAdmin : Cross Site Scripting de libraries

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un attaque de type Cross Site Scripting dans phpMyAdmin.
Produits vulnérables : Fedora, openSUSE, phpMyAdmin, SLES, TurboLinux.
Gravité de cette faille : 2/4.
Date de création : 24/06/2008.
Références de ce bulletin : CVE-2008-2960, FEDORA-2008-5640, FEDORA-2008-5676, MDVSA-2008:131, PMASA-2008-4, SUSE-SR:2009:003, TLSA-2008-29, VIGILANCE-VUL-7908.

Description de la vulnérabilité 

Le programme phpMyAdmin permet d'administrer une base de données MySQL.

Le répertoire /libraries contient plusieurs fichiers qui affichent les arguments reçus sans les filtrer. Cette vulnérabilité peut être exploitée lorsque register_globals est activé et lorsque le fichier ".htaccess" situé dans le répertoire /libraries est ignoré par Apache.

Un attaquant peut donc mener une attaque de type Cross Site Scripting, lorsque la victime est authentifiée sur phpMyAdmin.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de menace informatique concerne les logiciels ou systèmes comme Fedora, openSUSE, phpMyAdmin, SLES, TurboLinux.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de vulnérabilité informatique.

Solutions pour cette menace 

phpMyAdmin : version 2.11.7.
La version 2.11.7 est corrigée :
  http://www.phpmyadmin.net/

Fedora : nouveaux paquetages phpMyAdmin.
De nouveaux paquetages sont disponibles :
  phpMyAdmin-2.11.7-1.fc8
  phpMyAdmin-2.11.7-1.fc9

Mandriva : nouveaux paquetages phpMyAdmin.
De nouveaux paquetages sont disponibles :
 
 Corporate 4.0:
 e0808e7ccb437c0da416c979605d0f9f corporate/4.0/i586/phpMyAdmin-2.11.7-0.1.20060mlcs4.noarch.rpm
 31c0d1f53b3b9ca46cfb057fea859428 corporate/4.0/SRPMS/phpMyAdmin-2.11.7-0.1.20060mlcs4.src.rpm
 Corporate 4.0/X86_64:
 e0808e7ccb437c0da416c979605d0f9f corporate/4.0/x86_64/phpMyAdmin-2.11.7-0.1.20060mlcs4.noarch.rpm
 31c0d1f53b3b9ca46cfb057fea859428 corporate/4.0/SRPMS/phpMyAdmin-2.11.7-0.1.20060mlcs4.src.rpm

SUSE : nouveaux paquetages boinc-client, xrdp, phpMyAdmin, libnasl, moodle, xrdp, net-snmp, audiofile, XFree86/xterm, amarok, libpng, sudo, avahi.
De nouveaux paquetages sont disponibles.

Turbolinux : nouveaux paquetages phpmyadmin.
De nouveaux paquetages sont disponibles :
  Turbolinux Appliance Server 3.0 : phpmyadmin-2.11.7-1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces cyber-sécurité. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.