L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de qmail : déni de service sur les architectures 64 bits

Synthèse de la vulnérabilité 

Lorsque qmail est installé sur une machine 64 bits, un attaquant distant peut mener trois dénis de service.
Systèmes impactés : Debian, Ubuntu, Unix (plateforme) ~ non exhaustif.
Gravité de cette alerte : 1/4.
Nombre de vulnérabilités dans ce bulletin : 3.
Date de création : 09/05/2005.
Dates de révisions : 10/05/2005, 16/05/2005, 01/06/2005.
Références de cette alerte : BID-13528, BID-13535, BID-13536, CVE-2005-1513, CVE-2005-1514, CVE-2005-1515, DLA-2234-1, DSA-4692-1, USN-4556-1, USN-4621-1, V6-UNIXQMAIL64BDOS, VIGILANCE-VUL-4955.

Description de la vulnérabilité 

Le serveur de messagerie qmail est sensible à trois dénis de service, lorsqu'il est installé sur une machine 64 bits.

Un débordement d'entier se produit dans la fonction stralloc_readyplus().

Une erreur de segmentation peut se produire dans le fichier commands.c.

Un débordement d'entier se produit dans la fonction qmail_put().

Pour provoquer ces erreurs, un attaquant doit se connecter sur le service et lui envoyer des données illicites. Une erreur est aussi présente dans qmail-pop3d.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité cyber-sécurité concerne les logiciels ou systèmes comme Debian, Ubuntu, Unix (plateforme) ~ non exhaustif.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de menace est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Ce bulletin concerne 3 vulnérabilités.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence débutant peut exploiter cet avis de menace.

Solutions pour cette menace 

qmail : contre-mesure.
Il est recommandé de ne pas installer qmail sur une machine 64 bits, tant que le support n'est pas stabilisé.

Debian 8 : nouveaux paquetages netqmail.
De nouveaux paquetages sont disponibles :
  Debian 8 : netqmail 1.06-6.2~deb8u1

Debian 9-10 : nouveaux paquetages netqmail.
De nouveaux paquetages sont disponibles :
  Debian 9 : netqmail 1.06-6.2~deb9u1
  Debian 10 : netqmail 1.06-6.2~deb10u1

Ubuntu 20.04 : nouveaux paquetages netqmail.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : qmail 1.06-6.2~deb10u1build0.20.04.1

Ubuntu : nouveaux paquetages netqmail.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : qmail 1.06-6.2~deb10u1build0.18.04.1
  Ubuntu 16.04 LTS : qmail 1.06-6.2~deb10u1build0.16.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilité de logiciel. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.