L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de strongSwan : corruption de mémoire via stroke_socket.c

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via stroke_socket.c de strongSwan, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes vulnérables : Debian, Fedora, openSUSE Leap, pfSense, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette menace : 3/4.
Date de création : 28/05/2018.
Références de cette faille : CVE-2018-5388, DSA-4229-1, FEDORA-2018-3731a89e20, openSUSE-SU-2019:2594-1, openSUSE-SU-2019:2598-1, SUSE-SU-2019:3056-1, SUSE-SU-2019:3266-1, USN-3771-1, VIGILANCE-VUL-26240, VU#338343.

Description de la vulnérabilité 

Un attaquant peut provoquer une corruption de mémoire via stroke_socket.c de strongSwan, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin cyber-sécurité concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, pfSense, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille informatique est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de menace.

Solutions pour cette menace 

Debian : nouveaux paquetages strongswan.
De nouveaux paquetages sont disponibles :
  Debian 8 : strongswan 5.2.1-6+deb8u6
  Debian 9 : strongswan 5.5.1-4+deb9u2

Fedora 28 : nouveaux paquetages strongswan.
De nouveaux paquetages sont disponibles :
  Fedora 28 : strongswan 5.6.2-6.fc28

openSUSE Leap 15 : nouveaux paquetages strongswan.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : strongswan 5.6.0-lp150.3.3.1
  openSUSE Leap 15.1 : strongswan 5.6.0-lp151.4.3.1

pfSense : version 2.4.4.
La version 2.4.4 est corrigée :
  https://www.netgate.com/

SUSE LE 12 : nouveaux paquetages strongswan.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : strongswan 5.1.3-26.13.1
  SUSE LE 12 SP2 : strongswan 5.1.3-26.13.1
  SUSE LE 12 SP3 : strongswan 5.1.3-26.13.1
  SUSE LE 12 SP4 : strongswan 5.1.3-26.13.1
  SUSE LE 12 SP5 : strongswan 5.1.3-26.13.1

SUSE LE 15 : nouveaux paquetages strongswan.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : strongswan 5.6.0-4.3.2

Ubuntu : nouveaux paquetages strongswan.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : strongswan 5.6.2-1ubuntu2.2
  Ubuntu 16.04 LTS : strongswan 5.3.5-1ubuntu3.7
  Ubuntu 14.04 LTS : strongswan 5.1.2-0ubuntu2.10
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif cyber-sécurité. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.