L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de tcpdump : lecture de mémoire hors plage prévue via EXTRACT_32BITS

Synthèse de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via EXTRACT_32BITS() de tcpdump, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Produits impactés : Mac OS X, Debian, BIG-IP Hardware, TMOS, Fedora, AIX, openSUSE Leap, Solaris, RHEL, RSA Authentication Manager, Slackware, SUSE Linux Enterprise Desktop, SLES, tcpdump, Ubuntu.
Gravité de ce bulletin : 2/4.
Nombre de vulnérabilités dans ce bulletin : 2.
Date de création : 17/03/2020.
Références de cette menace : bulletinapr2020, CVE-2018-14466, CVE-2018-19325-REJECT, DLA-1955-1, DLA-1967-1, DSA-2019-168, DSA-2019-169, DSA-4547-1, FEDORA-2019-6db0d5b9d9, FEDORA-2019-85d92df70f, FEDORA-2019-b92ce3144a, FEDORA-2019-d06bc63433, FEDORA-2019-eaa681d33e, HT210788, K04367730, K44551633, K56551263, K86252029, openSUSE-SU-2019:2343-1, openSUSE-SU-2019:2344-1, openSUSE-SU-2019:2345-1, openSUSE-SU-2019:2348-1, RHSA-2020:4760-01, SSA:2019-274-01, SUSE-SU-2019:14191-1, SUSE-SU-2019:2669-1, SUSE-SU-2019:2674-1, SUSE-SU-2020:3360-1, USN-4221-1, USN-4221-2, USN-4252-1, USN-4252-2, VIGILANCE-VUL-31803.

Description de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via EXTRACT_32BITS() de tcpdump, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Mac OS X, Debian, BIG-IP Hardware, TMOS, Fedora, AIX, openSUSE Leap, Solaris, RHEL, RSA Authentication Manager, Slackware, SUSE Linux Enterprise Desktop, SLES, tcpdump, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Ce bulletin concerne 2 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

tcpdump : version 4.9.3.
La version 4.9.3 est corrigée :
  http://www.tcpdump.org/

tcpdump : solution pour EXTRACT_32BITS.
La solution VIGILANCE-SOL-68552 est disponible.

AIX : patch pour tcpdump.
Un patch est indiqué dans les sources d'information.

Apple macOS : version 10.13.6-2019-007.
La version 10.13.6-2019-007 est corrigée :
  https://support.apple.com/

Apple macOS : version 10.14.6-2019-002.
La version 10.14.6-2019-002 est corrigée :
  https://support.apple.com/

Apple macOS : version 10.15.2.
La version 10.15.2 est corrigée :
  https://support.apple.com/

Debian 8 : nouveaux paquetages libpcap.
De nouveaux paquetages sont disponibles :
  Debian 8 : libpcap 1.6.2-2+deb8u1

Debian 8 : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  Debian 8 : tcpdump 4.9.3-1~deb8u1

Debian 9/10 : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  Debian 9 : tcpdump 4.9.3-1~deb9u1
  Debian 10 : tcpdump 4.9.3-1~deb10u1

F5 BIG-IP : solution pour tcpdump.
La solution est indiquée dans les sources d'information.

Fedora : nouveaux paquetages libpcap.
De nouveaux paquetages sont disponibles :
  Fedora 29 : libpcap 1.9.1-1.fc29
  Fedora 30 : libpcap 1.9.1-1.fc30

Fedora : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  Fedora 29 : tcpdump 4.9.3-1.fc29
  Fedora 30 : tcpdump 4.9.3-1.fc30
  Fedora 31 : tcpdump 4.9.3-1.fc31

openSUSE Leap 15 : nouveaux paquetages libpcap.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : libpcap 1.8.1-lp150.3.3.1
  openSUSE Leap 15.1 : libpcap 1.8.1-lp151.4.3.1

openSUSE Leap 15 : nouveaux paquetages tcpdump (21/10/2019).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : tcpdump 4.9.2-lp150.10.1
  openSUSE Leap 15.1 : tcpdump 4.9.2-lp151.4.6.1

Oracle Solaris : patch pour logiciels tiers de avril 2020 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 8 : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  RHEL 8.0-8.2 : tcpdump 4.9.3-1.el8

RSA Authentication Manager : version 8.4 P8.
La version 8.4 P8 est corrigée :
  https://www.dell.com/

Slackware : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : tcpdump 4.9.3-*-1_slack14.0
  Slackware 14.1 : tcpdump 4.9.3-*-1_slack14.1
  Slackware 14.2 : tcpdump 4.9.3-*-1_slack14.2

SUSE LE 11 : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : tcpdump 3.9.8-1.30.13.1
  SUSE LE 11 SP4 : tcpdump 3.9.8-1.30.13.1

SUSE LE 12 : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : tcpdump 4.9.2-14.14.1
  SUSE LE 12 SP2 : tcpdump 4.9.2-14.14.1
  SUSE LE 12 SP3 : tcpdump 4.9.2-14.14.1
  SUSE LE 12 SP4 : tcpdump 4.9.2-14.14.1
  SUSE LE 12 SP5 : tcpdump 4.9.2-14.14.1

SUSE LE 12 SP5 : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : tcpdump 4.9.2-14.17.1

SUSE LE 15 : nouveaux paquetages tcpdump (16/10/2019).
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : tcpdump 4.9.2-3.9.1
  SUSE LE 15 SP1 : tcpdump 4.9.2-3.9.1

Ubuntu : nouveaux paquetages libpcap.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : libpcap0.8 1.8.1-6ubuntu1.19.04.1
  Ubuntu 18.04 LTS : libpcap0.8 1.8.1-6ubuntu1.18.04.1
  Ubuntu 16.04 LTS : libpcap0.8 1.7.4-2ubuntu0.1
  Ubuntu 14.04 ESM : libpcap0.8 1.5.3-2ubuntu0.1
  Ubuntu 12.04 ESM : libpcap0.8 1.1.1-10ubuntu0.1

Ubuntu : nouveaux paquetages tcpdump.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : tcpdump 4.9.3-0ubuntu0.18.04.1
  Ubuntu 16.04 LTS : tcpdump 4.9.3-0ubuntu0.16.04.1
  Ubuntu 14.04 ESM : tcpdump 4.9.3-0ubuntu0.14.04.1+esm1
  Ubuntu 12.04 ESM : tcpdump 4.9.3-0ubuntu0.12.04.1

Wind River Linux : version 10.17.41.19.
La version 10.17.41.19 est corrigée.

Wind River Linux : version 10.17.41.20.
La version 10.17.41.20 est corrigée :
  https://support2.windriver.com/

Wind River Linux : version 10.18.44.15.
La version 10.18.44.15 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilité applicative. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.