L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de wpasupplicant : déréférencement de pointeur NULL via eap_server_pwd.c, eap_pwd.c

Synthèse de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via eap_server_pwd.c, eap_pwd.c de wpasupplicant, afin de mener un déni de service.
Produits vulnérables : Debian, Fedora, FreeBSD, pfSense, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 07/05/2019.
Références de ce bulletin : CVE-2019-11555, DLA-1867-1, DSA-4450-1, FEDORA-2019-28d3ca93d2, FEDORA-2019-d6bc3771a4, FEDORA-2019-ff1b728d09, FreeBSD-SA-19:03.wpa, USN-3969-1, USN-3969-2, VIGILANCE-VUL-29244.

Description de la vulnérabilité 

Un attaquant peut forcer le déréférencement d'un pointeur NULL via eap_server_pwd.c, eap_pwd.c de wpasupplicant, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité concerne les logiciels ou systèmes comme Debian, Fedora, FreeBSD, pfSense, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cyber-sécurité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages wpa.
De nouveaux paquetages sont disponibles :
  Debian 8 : wpa 2.3-1+deb8u8

Debian 9 : nouveaux paquetages wpa.
De nouveaux paquetages sont disponibles :
  Debian 9 : wpa 2:2.4-1+deb9u4

Fedora 30 : nouveaux paquetages wpa_supplicant.
De nouveaux paquetages sont disponibles :
  Fedora 30 : wpa_supplicant 2.8-2.fc30

Fedora : nouveaux paquetages hostapd.
De nouveaux paquetages sont disponibles :
  Fedora 29 : hostapd 2.8-1.fc29
  Fedora 30 : hostapd 2.8-1.fc30

FreeBSD : patch pour wpa_supplicant.
Un patch est disponible :
  FreeBSD 12.0 : https://security.freebsd.org/patches/SA-19:03/wpa-12.patch
  FreeBSD 11.2 : https://security.freebsd.org/patches/SA-19:03/wpa-11.patch

pfSense : version 2.4.4-p3.
La version 2.4.4-p3 est corrigée.

Ubuntu : nouveaux paquetages wpasupplicant.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : hostapd 2:2.6-21ubuntu3.1, wpasupplicant 2:2.6-21ubuntu3.1
  Ubuntu 18.10 : hostapd 2:2.6-18ubuntu1.2, wpasupplicant 2:2.6-18ubuntu1.2
  Ubuntu 18.04 LTS : hostapd 2:2.6-15ubuntu2.3, wpasupplicant 2:2.6-15ubuntu2.3
  Ubuntu 16.04 LTS : hostapd 2.4-0ubuntu6.5, wpasupplicant 2.4-0ubuntu6.5
  Ubuntu 14.04 ESM : hostapd 2.1-0ubuntu1.7+esm1, wpasupplicant 2.1-0ubuntu1.7+esm1

Wind River Linux : solution (21/05/2019).
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilité applicative. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.