L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

Vulnérabilités informatiques de FreeSWAN

bulletin de vulnérabilité CVE-2004-0590

Erreur d'authentification de strongSwan/openswan

Synthèse de la vulnérabilité

Les programmes de la famille strongSwan/Openswan ne vérifient pas correctement les certificats proposés par les clients.
Produits concernés : Arkoon FAST360, FreeSWAN, Mandriva Linux, Openswan, Unix (plateforme) ~ non exhaustif.
Gravité : 3/4.
Conséquences : accès/droits utilisateur.
Provenance : serveur internet.
Date création : 28/06/2004.
Dates révisions : 30/06/2004, 15/07/2004, 21/09/2004.
Références : CERTA-2004-AVI-245, CVE-2004-0590, MDKSA-2004:070, MDKSA-2004:070-1, V6-UNIXSWANX509USUR, VIGILANCE-VUL-4243.

Description de la vulnérabilité

Les programmes FreeS/WAN, openswan, strongSwan et FreeS/WAN sont issus du même code source. Ils permettent de créer des tunnels VPN.

Les clients VPN doivent normalement présenter des certificats X.509 valides afin d'être autorisés à se connecter sur ces serveurs.

Cependant, un attaquant peut usurper l'identité d'un utilisateur en créant un certificat spécial. La création de ce certificat nécessite de connaître le Distinguished Name de l'utilisateur. Cette vulnérabilité permet alors à un attaquant de se connecter sur le service VPN.

Lorqu'un client VPN présente un certificat X.509 dont la chaîne de certification contient une boucle, une boucle infinie se produit sur le serveur. Cette vulnérabilité permet ainsi de mener un déni de service.

Les programmes suivants sont sensibles à ces 2 vulnérabilités :
 - Arkoon < 3.0/19
 - FreeS/WAN 1.x avec le patch X.509 < 0.9.41
 - FreeS/WAN 2.x avec le patch X.509 < 1.6.1
 - openswan 1.x < 1.0.6
 - openswan 2.x < 2.1.4
 - strongSwan < 2.1.3
 - superfreeswan 1.x
Bulletin Vigil@nce complet... (Essai gratuit)

alerte de vulnérabilité informatique CVE-2002-0666

Déni de service à l'aide de paquets IPSec

Synthèse de la vulnérabilité

En utilisant des paquets IPSec malformés, un attaquant du réseau peut bloquer le système.
Produits concernés : Debian, FreeBSD, FreeSWAN, AIX, NetBSD, Unix (plateforme) ~ non exhaustif.
Gravité : 3/4.
Conséquences : déni de service du serveur.
Provenance : serveur internet.
Date création : 18/10/2002.
Dates révisions : 21/10/2002, 22/10/2002, 03/12/2002, 05/12/2002.
Références : BID-6011, CERTA-2002-AVI-261, CVE-2002-0666, DSA-201, DSA-201-1, IBM-OAR-2002-1075, MSS-OAR-E01-2002:1075.1, NetBSD 2002-016, NetBSD-SA2002-016, V6-UNIXIPSECSMALLLEN, VIGILANCE-VUL-3066, VU#459371.

Description de la vulnérabilité

Les produits KAME et FreeS/WAN implémentent le protocole IPSec.

Afin de valider l'intégrité des paquets IPSec, ceux-ci contiennent un checksum. Le destinataire des paquets recalcule alors cette valeur (Integrity Check Value) et la compare avant d'accepter le paquet.

Cependant lorsqu'un paquet est très petit, une erreur de logique a pour conséquence que la taille du calcul de l'ICV devient négative (-4). Comme cette taille est employée de manière non signée, elle correspond à une très grande valeur positive (+4294967292). Ainsi, lors de son utilisation, une erreur d'accès mémoire apparaît, ce qui provoque un kernel panic.

Cette vulnérabilité permet donc à un attaquant distant de mener un déni de service.
Bulletin Vigil@nce complet... (Essai gratuit)
Notre base de données contient d'autres bulletins. Vous pouvez utiliser un essai gratuit pour les consulter.