The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

Computer vulnerabilities of Cisco Prime Collaboration Manager

computer threat announce CVE-2016-0702 CVE-2016-0705 CVE-2016-0797

OpenSSL: seven vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of OpenSSL.
Severity: 2/4.
Number of vulnerabilities in this bulletin: 7.
Creation date: 01/03/2016.
Revision date: 07/03/2016.
Identifiers: 000008897, 046178, 046208, 1979498, 1979602, 1987779, 1993210, 2003480, 2003620, 2003673, 2012827, 2013020, 2014202, 2014651, 2014669, 2015080, 2016039, 7043086, 9010066, 9010067, 9010072, BSA-2016-004, bulletinapr2016, bulletinjan2016, CERTFR-2016-AVI-076, CERTFR-2016-AVI-080, cisco-sa-20160302-openssl, CTX208403, CVE-2016-0702, CVE-2016-0705, CVE-2016-0797, CVE-2016-0798, CVE-2016-0799, CVE-2016-0800, CVE-2016-2842, DSA-3500-1, ESA-2016-080, FEDORA-2016-2802690366, FEDORA-2016-e1234b65a2, FEDORA-2016-e6807b3394, FreeBSD-SA-16:12.openssl, HPESBHF03741, ibm10732391, ibm10733905, ibm10738249, ibm10738401, JSA10722, JSA10759, K22334603, K52349521, K93122894, MBGSA-1602, NTAP-20160301-0001, NTAP-20160303-0001, NTAP-20160321-0001, openSUSE-SU-2016:0627-1, openSUSE-SU-2016:0628-1, openSUSE-SU-2016:0637-1, openSUSE-SU-2016:0638-1, openSUSE-SU-2016:0640-1, openSUSE-SU-2016:0720-1, openSUSE-SU-2016:1566-1, openSUSE-SU-2017:1211-1, openSUSE-SU-2017:1212-1, PAN-SA-2016-0020, PAN-SA-2016-0028, PAN-SA-2016-0030, RHSA-2016:0301-01, RHSA-2016:0302-01, RHSA-2016:0303-01, RHSA-2016:0304-01, RHSA-2016:0305-01, RHSA-2016:0306-01, RHSA-2016:0372-01, RHSA-2016:0445-01, RHSA-2016:0446-01, RHSA-2016:0490-01, RHSA-2016:1519-01, RHSA-2016:2073-01, RHSA-2018:2568-01, RHSA-2018:2575-01, SA117, SA40168, SB10156, SOL22334603, SOL40524634, SOL52349521, SOL79215841, SOL93122894, SSA:2016-062-02, SSA-623229, SUSE-SU-2016:0617-1, SUSE-SU-2016:0620-1, SUSE-SU-2016:0621-1, SUSE-SU-2016:0624-1, SUSE-SU-2016:0631-1, SUSE-SU-2016:0641-1, SUSE-SU-2016:0678-1, SUSE-SU-2018:2839-1, SUSE-SU-2018:3082-1, TNS-2016-03, USN-2914-1, VIGILANCE-VUL-19060, VN-2016-004, VU#583776.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

Several vulnerabilities were announced in OpenSSL.

An attacker can act as a Man-in-the-Middle on a server supporting SSLv2 and EXPORT ciphers (this configuration is considered as weak since several years), in order to read or write data in the session. [severity:2/4; CVE-2016-0800, VU#583776]

An attacker can force the usage of a freed memory area when OpenSSL processes a DSA private key (this scenario is rare), in order to trigger a denial of service, and possibly to run code. [severity:2/4; CVE-2016-0705]

An attacker can read a memory fragment via SRP_VBASE_get_by_user, in order to obtain sensitive information. [severity:1/4; CVE-2016-0798]

An attacker can force a NULL pointer to be dereferenced in BN_hex2bn(), in order to trigger a denial of service. [severity:1/4; CVE-2016-0797]

An attacker can use a very large string (size INT_MAX), to generate a memory corruption in the BIO_*printf() functions, in order to trigger a denial of service, and possibly to run code. [severity:2/4; CVE-2016-0799]

An attacker can use cache conflicts on Intel Sandy-Bridge, in order to obtain RSA keys. [severity:1/4; CVE-2016-0702]

An attacker can use a very large string (size INT_MAX), to generate a memory corruption in the internal doapr_outch() function, in order to trigger a denial of service, and possibly to run code. [severity:2/4; CVE-2016-2842]
Full Vigil@nce bulletin... (Free trial)

weakness note CVE-2016-0703 CVE-2016-0704

OpenSSL: two vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of OpenSSL.
Severity: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 01/03/2016.
Identifiers: 046178, 046208, 1979498, 9010067, BSA-2016-004, bulletinapr2016, bulletinjan2016, CERTFR-2016-AVI-076, CERTFR-2016-AVI-080, cisco-sa-20160302-openssl, CVE-2016-0703, CVE-2016-0704, FreeBSD-SA-16:12.openssl, HPESBHF03741, JSA10759, NTAP-20160303-0001, openSUSE-SU-2016:0627-1, openSUSE-SU-2016:0628-1, openSUSE-SU-2016:0638-1, openSUSE-SU-2016:0720-1, PAN-SA-2016-0030, RHSA-2016:0372-01, SA117, SA40168, SOL95463126, SUSE-SU-2016:0617-1, SUSE-SU-2016:0620-1, SUSE-SU-2016:0621-1, SUSE-SU-2016:0624-1, SUSE-SU-2016:0631-1, SUSE-SU-2016:0641-1, SUSE-SU-2016:0678-1, TNS-2016-03, VIGILANCE-VUL-19061.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

Several vulnerabilities were announced in OpenSSL.

The 2_srvr.c file did not enforce that clear-key-length is zero for non-export ciphers, so an attacker can act as a Man-in-the-Middle on SSLv2, in order to read or write data in the session. [severity:2/4; CVE-2016-0703]

The 2_srvr.c file overwrite some byte dur the Bleichenbacher protection, so an attacker can act as a Man-in-the-Middle on SSLv2, in order to read or write data in the session. [severity:2/4; CVE-2016-0704]
Full Vigil@nce bulletin... (Free trial)

cybersecurity announce 18918

Cisco Prime Collaboration Provisioning: privilege escalation via the admininistrationinterface

Synthesis of the vulnerability

An attacker can send a specially crafted command to the administration interface of Cisco Prime Collaboration Provisioning, in order to get administration privileges on the operating system.
Severity: 2/4.
Creation date: 10/02/2016.
Identifiers: CERTFR-2016-AVI-061, cisco-sa-20160209-pcp, VIGILANCE-VUL-18918.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Cisco Prime Collaboration Provisioning product includes a command line interface for administration purpose.

However, this program does not rightly validate its input, and there are some command strings that provides access to a root shell on the underlying Linux system.

An attacker can therefore send a specially crafted command to the administration interface of Cisco Prime Collaboration Provisioning, in order to get administration privileges on the operating system.
Full Vigil@nce bulletin... (Free trial)

cybersecurity weakness CVE-2015-4307

Cisco Prime Collaboration Provisioning: privilege escalation

Synthesis of the vulnerability

An attacker can use Cisco Prime Collaboration Provisioning, in order to escalate his privileges.
Severity: 2/4.
Creation date: 17/09/2015.
Identifiers: CERTFR-2015-AVI-396, cisco-sa-20150916-pcp, CSCut64111, CVE-2015-4307, VIGILANCE-VUL-17907.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Cisco Prime Collaboration Provisioning product offers a web service.

However, using a malicious url, an authenticated attacker can create an administrative account.

An attacker can therefore use Cisco Prime Collaboration Provisioning, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

security bulletin CVE-2015-4295

Cisco Unified Communications Manager: information disclosure via Prime Collaboration Deployment

Synthesis of the vulnerability

An attacker can use a vulnerability in Prime Collaboration Deployment of Cisco Unified Communications Manager, in order to obtain sensitive information.
Severity: 2/4.
Creation date: 31/07/2015.
Identifiers: 40223, CSCuv21819, CVE-2015-4295, VIGILANCE-VUL-17551.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Cisco Unified Communications Manager product offers a web service.

However, an attacker can use an url to bypass access restrictions to data, and to view system root credentials.

An attacker can therefore use a vulnerability in Prime Collaboration Deployment of Cisco Unified Communications Manager, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

security bulletin CVE-2015-4188

Cisco Prime Collaboration Manager: SQL injection of the interface Web

Synthesis of the vulnerability

An attacker can use a SQL injection in the Web interface of Cisco Prime Collaboration, in order to read or alter data.
Severity: 2/4.
Creation date: 17/06/2015.
Identifiers: 39365, CVE-2015-4188, VIGILANCE-VUL-17155.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Cisco Prime Collaboration product uses a database.

However, request data from the URL are directly inserted in a SQL query.

An unauthenticated attacker can therefore use a SQL injection in the Web interface of Cisco Prime Collaboration, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

cybersecurity alert CVE-2014-0224

OpenSSL: man in the middle via ChangeCipherSpec

Synthesis of the vulnerability

An attacker can act as a man in the middle between a client and a server using OpenSSL, in order to read or alter exchanged data.
Severity: 3/4.
Creation date: 05/06/2014.
Revision date: 05/06/2014.
Identifiers: 1676496, 1690827, aid-06062014, c04336637, c04347622, c04363613, CERTFR-2014-AVI-253, CERTFR-2014-AVI-254, CERTFR-2014-AVI-255, CERTFR-2014-AVI-260, CERTFR-2014-AVI-274, CERTFR-2014-AVI-279, CERTFR-2014-AVI-286, CERTFR-2014-AVI-513, cisco-sa-20140605-openssl, cpuoct2016, CTX140876, CVE-2014-0224, DOC-53313, DSA-2950-1, DSA-2950-2, FEDORA-2014-17576, FEDORA-2014-17587, FEDORA-2014-7101, FEDORA-2014-7102, FG-IR-14-018, FreeBSD-SA-14:14.openssl, HPSBHF03052, HPSBUX03046, JSA10629, MDVSA-2014:105, MDVSA-2014:106, MDVSA-2015:062, NetBSD-SA2014-006, openSUSE-SU-2014:0764-1, openSUSE-SU-2014:0765-1, openSUSE-SU-2015:0229-1, openSUSE-SU-2016:0640-1, RHSA-2014:0624-01, RHSA-2014:0625-01, RHSA-2014:0626-01, RHSA-2014:0627-01, RHSA-2014:0628-01, RHSA-2014:0629-01, RHSA-2014:0630-01, RHSA-2014:0631-01, RHSA-2014:0632-01, RHSA-2014:0633-01, RHSA-2014:0679-01, RHSA-2014:0680-01, SA40006, SA80, SB10075, sk101186, SOL15325, SPL-85063, SSA:2014-156-03, SSA-234763, SSRT101590, SUSE-SU-2014:0759-1, SUSE-SU-2014:0759-2, SUSE-SU-2014:0761-1, SUSE-SU-2014:0762-1, USN-2232-1, USN-2232-2, USN-2232-3, USN-2232-4, VIGILANCE-VUL-14844, VMSA-2014-0006, VMSA-2014-0006.1, VMSA-2014-0006.10, VMSA-2014-0006.11, VMSA-2014-0006.2, VMSA-2014-0006.3, VMSA-2014-0006.4, VMSA-2014-0006.5, VMSA-2014-0006.6, VMSA-2014-0006.7, VMSA-2014-0006.8, VMSA-2014-0006.9, VU#978508.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The OpenSSL product implements SSL/TLS, which uses a handshake.

However, by using a handshake with a ChangeCipherSpec message, an attacker can force the usage of weak keys.

An attacker can therefore act as a man in the middle between a client and a server using OpenSSL, in order to read or alter exchanged data.
Full Vigil@nce bulletin... (Free trial)

weakness CVE-2014-3470

OpenSSL: denial of service via ECDH

Synthesis of the vulnerability

An attacker, who is located on a TLS server, can use Anonymous ECDH, in order to trigger a denial of service in OpenSSL client applications.
Severity: 2/4.
Creation date: 05/06/2014.
Identifiers: 1676496, aid-06062014, c04336637, c04363613, c04368523, CERTFR-2014-AVI-253, CERTFR-2014-AVI-254, CERTFR-2014-AVI-255, CERTFR-2014-AVI-260, CERTFR-2014-AVI-274, CERTFR-2014-AVI-279, CERTFR-2014-AVI-286, cisco-sa-20140605-openssl, CTX140876, CVE-2014-3470, DOC-53313, DSA-2950-1, DSA-2950-2, FEDORA-2014-17576, FEDORA-2014-17587, FEDORA-2014-7101, FEDORA-2014-7102, FG-IR-14-018, FreeBSD-SA-14:14.openssl, HPSBMU03069, HPSBUX03046, JSA10629, MDVSA-2014:105, MDVSA-2014:106, MDVSA-2015:062, NetBSD-SA2014-006, openSUSE-SU-2014:0764-1, openSUSE-SU-2014:0765-1, openSUSE-SU-2016:0640-1, RHSA-2014:0625-01, RHSA-2014:0628-01, RHSA-2014:0679-01, SA40006, SA80, SB10075, SPL-85063, SSA:2014-156-03, SSA-234763, SSRT101590, SUSE-SU-2014:0759-1, SUSE-SU-2014:0759-2, SUSE-SU-2014:0761-1, SUSE-SU-2014:0762-1, USN-2232-1, USN-2232-2, USN-2232-3, USN-2232-4, VIGILANCE-VUL-14847, VMSA-2014-0006, VMSA-2014-0006.1, VMSA-2014-0006.10, VMSA-2014-0006.11, VMSA-2014-0006.2, VMSA-2014-0006.3, VMSA-2014-0006.4, VMSA-2014-0006.5, VMSA-2014-0006.6, VMSA-2014-0006.7, VMSA-2014-0006.8, VMSA-2014-0006.9.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

A client based on the OpenSSL library can create an encrypted session using elliptic curves (ECDH : elliptic curves and Diffie-Hellman).

However, a malicious server can negotiate an Anonymous ECDH ciphersuite, in order to trigger a denial of service in the OpenSSL client.

An attacker, who is located on a TLS server, can therefore use Anonymous ECDH, in order to trigger a denial of service in OpenSSL client applications.
Full Vigil@nce bulletin... (Free trial)

computer threat bulletin CVE-2014-0076

OpenSSL: disclosure of ECDSA secret

Synthesis of the vulnerability

A local attacker can guess the ECDSA secret used by the OpenSSL implementation, in order to obtain sensitive information.
Severity: 1/4.
Creation date: 21/03/2014.
Revision date: 05/06/2014.
Identifiers: 1673696, 1681249, 1688949, c04336637, CERTFR-2014-AVI-179, CERTFR-2014-AVI-253, CERTFR-2014-AVI-254, CERTFR-2014-AVI-255, CERTFR-2014-AVI-279, CERTFR-2014-AVI-286, cisco-sa-20140605-openssl, CVE-2014-0076, DOC-53313, DSA-2908-1, FreeBSD-SA-14:06.openssl, HPSBUX03046, JSA10629, MDVSA-2014:067, MDVSA-2015:062, NetBSD-SA2014-006, openSUSE-SU-2014:0480-1, openSUSE-SU-2016:0640-1, pfSense-SA-14_04.openssl, SA40006, SB10075, SSA:2014-098-01, SSRT101590, SUSE-SU-2014:0759-1, SUSE-SU-2014:0761-1, SUSE-SU-2014:0762-1, USN-2165-1, VIGILANCE-VUL-14462.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The ECDSA (Elliptic Curve Digital Signature Algorithm) algorithm uses a secret "k" value.

However, a local attacker can monitor the process linked to OpenSSL, and use the "FLUSH+RELOAD Cache" attack on a conditional branch (if), to obtain bit after bit the "k" secret value.

A local attacker can therefore guess the ECDSA secret used by the OpenSSL implementation, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

security alert CVE-2010-5298

OpenSSL: data injection via OPENSSL_NO_BUF_FREELIST

Synthesis of the vulnerability

An attacker can establish a connection with a multi-thread application linked to OpenSSL with OPENSSL_NO_BUF_FREELIST, in order to potentially inject data in the session of another user.
Severity: 1/4.
Creation date: 14/04/2014.
Revision date: 05/06/2014.
Identifiers: 2167, aid-06062014, c04347622, CERTFR-2014-AVI-253, CERTFR-2014-AVI-254, CERTFR-2014-AVI-255, CERTFR-2014-AVI-260, CERTFR-2014-AVI-274, CERTFR-2014-AVI-279, CERTFR-2014-AVI-286, cisco-sa-20140605-openssl, CTX140876, CVE-2010-5298, DOC-53313, DSA-2908-1, FEDORA-2014-17576, FEDORA-2014-17587, FEDORA-2014-7101, FEDORA-2014-7102, FG-IR-14-018, FreeBSD-SA-14:09.openssl, HPSBHF03052, JSA10629, MDVSA-2014:090, MDVSA-2015:062, NetBSD-SA2014-006, openSUSE-SU-2014:0592-1, RHSA-2014:0625-01, RHSA-2014:0628-01, RHSA-2014:0679-01, SA40006, SA80, SB10075, SOL15328, SSA:2014-156-03, SSA-234763, USN-2192-1, VIGILANCE-VUL-14585, VMSA-2014-0006, VMSA-2014-0006.1, VMSA-2014-0006.10, VMSA-2014-0006.11, VMSA-2014-0006.2, VMSA-2014-0006.3, VMSA-2014-0006.4, VMSA-2014-0006.5, VMSA-2014-0006.6, VMSA-2014-0006.7, VMSA-2014-0006.8, VMSA-2014-0006.9.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The OpenSSL product uses a proprietary implementation of malloc to manage its memory.

However, when this feature is disabled with OPENSSL_NO_BUF_FREELIST, a memory area is not freed, and the ssl3_setup_read_buffer() function can, in multi-thread mode, reuse data from another SSL session.

An attacker can therefore establish a connection with a multi-threaded application linked to OpenSSL with OPENSSL_NO_BUF_FREELIST, in order to potentially inject data in the session of another user.
Full Vigil@nce bulletin... (Free trial)
Our database contains other pages. You can request a free trial to read them.