The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of 7-Zip: two vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of 7-Zip.
Impacted software: 7-Zip, Debian, Fedora, openSUSE, openSUSE Leap, Solaris, Synology DS***, Synology RS***, Ubuntu.
Severity of this computer vulnerability: 3/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 12/05/2016.
Références of this announce: bulletinjan2018, bulletinoct2016, CERTFR-2016-AVI-168, CVE-2016-2334, CVE-2016-2335, DLA-510-1, DSA-3599-1, FEDORA-2016-430bc0f808, FEDORA-2016-bbcb0e4eb4, openSUSE-SU-2016:1464-1, openSUSE-SU-2016:1675-1, openSUSE-SU-2016:1850-1, TALOS-CAN-0093, TALOS-CAN-0094, USN-3913-1, VIGILANCE-VUL-19612.

Description of the vulnerability 

Several vulnerabilities were announced in 7-Zip.

An attacker can force a read at an invalid address with an UDF file, in order to trigger a denial of service, or to obtain sensitive information. [severity:2/4; CVE-2016-2335, TALOS-CAN-0094]

An attacker can generate a buffer overflow with an HFS file, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2016-2334, TALOS-CAN-0093]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat impacts software or systems such as 7-Zip, Debian, Fedora, openSUSE, openSUSE Leap, Solaris, Synology DS***, Synology RS***, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability alert is important.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity weakness.

Solutions for this threat 

7-Zip: version 16.00.
The version 16.00 is fixed:
  http://www.7-zip.org/

Debian: new p7zip packages.
New packages are available:
  Debian 8: p7zip 9.20.1~dfsg.1-4.1+deb8u2
  Debian 7: p7zip 9.20.1~dfsg.1-4+deb7u2

Fedora: new p7zip packages.
New packages are available:
  Fedora 23: p7zip 16.02-1.fc23
  Fedora 24: p7zip 16.02-1.fc24

openSUSE: new p7zip packages.
New packages are available:
  openSUSE 13.1: p7zip 9.20.1-10.6.1
  openSUSE 13.2: p7zip 9.20.1-12.6.1
  openSUSE Leap 42.1: p7zip 9.20.1-15.1

Oracle Solaris: patch for third party software of January 2018 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Solaris: patch for third party software of October 2016 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Synology DS/RS: version 6.0.1-7393.
The version 6.0.1-7393 is fixed:
  https://www.synology.com/

Ubuntu: new p7zip packages.
New packages are available:
  Ubuntu 16.04 LTS: p7zip 9.20.1~dfsg.1-4.2ubuntu0.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer security workaround. The technology watch team tracks security threats targeting the computer system.