The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of AccountsService: directory traversal via user_change_icon_file_authorized_cb

Synthesis of the vulnerability 

An attacker can traverse directories via user_change_icon_file_authorized_cb() of AccountsService, in order to read a file outside the service root path.
Impacted products: openSUSE Leap, Solaris, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Creation date: 06/11/2018.
Références of this threat: bulletinoct2018, CVE-2018-14036, openSUSE-SU-2018:3710-1, SUSE-SU-2018:3625-1, USN-4616-1, USN-4616-2, VIGILANCE-VUL-27699.

Description of the vulnerability 

An attacker can traverse directories via user_change_icon_file_authorized_cb() of AccountsService, in order to read a file outside the service root path.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability impacts software or systems such as openSUSE Leap, Solaris, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security announce is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this computer vulnerability note.

Solutions for this threat 

openSUSE Leap 15.0: new accountsservice packages.
New packages are available:
  openSUSE Leap 15.0: accountsservice 0.6.45-lp150.3.3.1

Oracle Solaris: patch for third party software of October 2018 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 15: new accountsservice packages.
New packages are available:
  SUSE LE 15 RTM: accountsservice 0.6.45-6.7.6

Ubuntu: new accountsservice packages.
New packages are available:
  Ubuntu 20.10: accountsservice 0.6.55-0ubuntu13.2, libaccountsservice0 0.6.55-0ubuntu13.2
  Ubuntu 20.04 LTS: accountsservice 0.6.55-0ubuntu12~20.04.4, libaccountsservice0 0.6.55-0ubuntu12~20.04.4
  Ubuntu 18.04 LTS: accountsservice 0.6.45-1ubuntu1.3, libaccountsservice0 0.6.45-1ubuntu1.3
  Ubuntu 16.04 LTS: accountsservice 0.6.40-2ubuntu11.6, libaccountsservice0 0.6.40-2ubuntu11.6
  Ubuntu 14.04 ESM: accountsservice 0.6.35-0ubuntu7.3+esm2, libaccountsservice0 0.6.35-0ubuntu7.3+esm2
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer vulnerability bulletins. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.