The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Adobe Acrobat/Reader: multiple vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Adobe Acrobat/Reader.
Impacted systems: Acrobat, Acrobat DC Classic, Acrobat DC Continuous.
Severity of this alert: 3/4.
Number of vulnerabilities in this bulletin: 34.
Creation date: 10/01/2017.
Références of this alert: APSB17-01, CERTFR-2017-AVI-005, CVE-2017-2939, CVE-2017-2940, CVE-2017-2941, CVE-2017-2942, CVE-2017-2943, CVE-2017-2944, CVE-2017-2945, CVE-2017-2946, CVE-2017-2947, CVE-2017-2948, CVE-2017-2949, CVE-2017-2950, CVE-2017-2951, CVE-2017-2952, CVE-2017-2953, CVE-2017-2954, CVE-2017-2955, CVE-2017-2956, CVE-2017-2957, CVE-2017-2958, CVE-2017-2959, CVE-2017-2960, CVE-2017-2961, CVE-2017-2962, CVE-2017-2963, CVE-2017-2964, CVE-2017-2965, CVE-2017-2966, CVE-2017-2967, CVE-2017-2970, CVE-2017-2971, CVE-2017-2972, CVE-2017-3009, CVE-2017-3010, TALOS-2016-0259, VIGILANCE-VUL-21539, ZDI-17-002, ZDI-17-003, ZDI-17-004, ZDI-17-005, ZDI-17-006, ZDI-17-007, ZDI-17-008, ZDI-17-009, ZDI-17-010, ZDI-17-011, ZDI-17-012, ZDI-17-013, ZDI-17-014, ZDI-17-015, ZDI-17-016, ZDI-17-017, ZDI-17-018, ZDI-17-019, ZDI-17-020, ZDI-17-021, ZDI-17-022, ZDI-17-023, ZDI-17-024, ZDI-17-025, ZDI-17-026, ZDI-17-027, ZDI-17-028, ZDI-17-029, ZDI-17-030, ZDI-17-031, ZDI-17-045, ZDI-17-111, ZDI-17-242.

Description of the vulnerability 

Several vulnerabilities were announced in Adobe Acrobat/Reader.

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2962, ZDI-17-026]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2950, ZDI-17-021]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2951, ZDI-17-022]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2955]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2956]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2957]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2958]

An attacker can force the usage of a freed memory area, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2961, ZDI-17-025]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2942]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2945]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2946, ZDI-17-003, ZDI-17-004]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2949, ZDI-17-005, ZDI-17-006, ZDI-17-007, ZDI-17-008, ZDI-17-009, ZDI-17-011, ZDI-17-012, ZDI-17-013, ZDI-17-015, ZDI-17-016, ZDI-17-017, ZDI-17-018, ZDI-17-019, ZDI-17-020, ZDI-17-028, ZDI-17-029]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2959, ZDI-17-023]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2966, ZDI-17-030]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2948]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2952]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2939, ZDI-17-111]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2940]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2941, ZDI-17-002]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2943]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2944]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2953]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2954]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2960, ZDI-17-024]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2963, ZDI-17-027]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2964, ZDI-17-014]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2965, ZDI-17-010]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2967, ZDI-17-031]

An attacker can bypass security features, in order to escalate his privileges. [severity:2/4; CVE-2017-2947]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2970, ZDI-17-045]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2971, TALOS-2016-0259]

An attacker can generate a buffer overflow, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-2972]

An attacker can bypass security features, in order to obtain sensitive information. [severity:2/4; CVE-2017-3009, ZDI-17-242]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:3/4; CVE-2017-3010]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability impacts software or systems such as Acrobat, Acrobat DC Classic, Acrobat DC Continuous.

Our Vigil@nce team determined that the severity of this security announce is important.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 34 vulnerabilities.

An attacker with a expert ability can exploit this computer vulnerability note.

Solutions for this threat 

Adobe Acrobat/Reader Continuous: version 15.023.20053.
The version 15.023.20053 is fixed:
  http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

Adobe Acrobat/Reader Classic: version 15.006.30279.
The version 15.006.30279 is fixed:
  http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

Adobe Acrobat/Reader Desktop: version 11.0.19.
The version 11.0.19 is fixed:
  http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer security announces. The Vigil@nce vulnerability database contains several thousand vulnerabilities.