The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Adobe Flash Player: three vulnerabilities

Synthesis of the vulnerability 

An attacker can invite the victim to visit a malicious site, calling Adobe Flash Player, in order to run code.
Impacted products: Flash Player, Chrome, Edge EdgeHTML, IE, openSUSE, Opera, RHEL, SUSE Linux Enterprise Desktop, SLES.
Severity of this bulletin: 4/4.
Number of vulnerabilities in this bulletin: 3.
Creation date: 15/10/2015.
Revision date: 16/10/2015.
Références of this threat: 2755801, APSA15-05, APSB15-27, CERTFR-2015-ALE-011-001, CERTFR-2015-AVI-434, CERTFR-2015-AVI-448, CVE-2015-7645, CVE-2015-7647, CVE-2015-7648, openSUSE-SU-2015:1768-1, openSUSE-SU-2015:1781-1, RHSA-2015:1913-01, RHSA-2015:2024-01, SUSE-SU-2015:1770-1, SUSE-SU-2015:1771-1, VIGILANCE-VUL-18111.

Description of the vulnerability 

Several vulnerabilities were announced in Adobe Flash Player.

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:4/4; APSA15-05, CERTFR-2015-ALE-011-001, CVE-2015-7645]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:4/4; CVE-2015-7647]

An attacker can generate a memory corruption, in order to trigger a denial of service, and possibly to run code. [severity:4/4; CVE-2015-7648]

An attacker can therefore invite the victim to visit a malicious site, calling Adobe Flash Player, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat bulletin impacts software or systems such as Flash Player, Chrome, Edge EdgeHTML, IE, openSUSE, Opera, RHEL, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this security threat is critical.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 3 vulnerabilities.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a beginner ability can exploit this computer vulnerability alert.

Solutions for this threat 

Adobe Flash Player Windows: version 19.0.0.226.
The version 19.0.0.226 is fixed:
  http://www.adobe.com/go/getflash
  http://www.adobe.com/products/players/flash-player-distribution.html

Adobe Flash Player Windows: version 18.0.0.255.
The version 18.0.0.255 is fixed:
  http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

Adobe Flash Player Linux: version 11.2.202.540.
The version 11.2.202.540 is fixed:
  http://www.adobe.com/go/getflash

Adobe Flash Player: workaround.
A workaround is to disable the plugin.

Google Chrome: version 46.0.2490.80.
The version 46.0.2490.80 is fixed:
  http://www.google.com/chrome/index.html?brand=CHNQ&utm_campaign=en&utm_source=en-et-chromeblog&utm_medium=et

Internet Explorer, Edge: patch for Adobe Flash Player.
A patch is available:
  https://support.microsoft.com/kb/3105216
The Microsoft announce indicates workarounds.

openSUSE 11.4: new flash-player packages.
New packages are available:
  openSUSE 11.4: flash-player 11.2.202.540-176.1

openSUSE: new flash-player packages.
New packages are available:
  openSUSE 13.1: flash-player 11.2.202.540-141.1
  openSUSE 13.2: flash-player 11.2.202.540-2.76.1

Opera: version 33.
The version 33 is fixed:
  http://www.opera.com/

RHEL 5: new flash-plugin packages.
New packages are available:
  RHEL 5: flash-plugin 11.2.202.548-1.el5

RHEL 6.7: new flash-plugin packages.
New packages are available:
  RHEL 6: flash-plugin 11.2.202.540-1.el6_7

SUSE LE: new flash-player packages.
New packages are available:
  SUSE LE 11 SP3: flash-player 11.2.202.540-0.23.1
  SUSE LE 11 SP4: flash-player 11.2.202.540-0.23.1
  SUSE LE 12 RTM: flash-player 11.2.202.540-108.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides cybersecurity patches. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.