The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Ansible Core: directory traversal via Home Directories

Synthesis of the vulnerability 

An attacker can traverse directories via Home Directories of Ansible Core, in order to create a file outside the service root path.
Vulnerable software: Ansible Core, Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 2/4.
Creation date: 20/02/2019.
Références of this computer vulnerability: CVE-2019-3828, DSA-4396-1, FEDORA-2019-7d1a63acc8, openSUSE-SU-2019:1125-1, openSUSE-SU-2019:1635-1, openSUSE-SU-2019:1858-1, USN-4072-1, VIGILANCE-VUL-28555.

Description of the vulnerability 

An attacker can traverse directories via Home Directories of Ansible Core, in order to create a file outside the service root path.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security vulnerability impacts software or systems such as Ansible Core, Debian, Fedora, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this security note.

Solutions for this threat 

Ansible Core: version 2.7.8.
The version 2.7.8 is fixed:
  https://releases.ansible.com/ansible/ansible-2.7.8.tar.gz

Ansible Core: version 2.6.14.
The version 2.6.14 is fixed:
  https://releases.ansible.com/ansible/ansible-2.6.14.tar.gz

Ansible Core: version 2.5.15.
The version 2.5.15 is fixed:
  https://github.com/ansible/ansible/

Ansible Core: patch for Home Directories.
A patch is indicated in information sources.

Debian 9: new ansible packages.
New packages are available:
  Debian 9: ansible 2.2.1.0-2+deb9u1

Fedora 29: new ansible packages.
New packages are available:
  Fedora 29: ansible 2.7.8-1.fc29

openSUSE Leap: new ansible packages.
New packages are available:
  openSUSE Leap 42.3: ansible 2.8.1-12.1
  openSUSE Leap 15.1: ansible 2.8.1-lp151.2.3.1
  openSUSE Leap 15.0: ansible 2.8.1-lp150.2.6.1
  SUSE LE 15 RTM-SP1: ansible 2.8.1-bp150.3.9.1
  SUSE LE 12 RTM-SP5: ansible 2.8.1-12.1

SUSE LE 12: new ansible packages.
New packages are available:
  SUSE LE 12 RTM-SP4: ansible 2.7.8-9.1

SUSE LE 15 SP1: new ansible packages.
New packages are available:
  SUSE LE 15 SP1: ansible 2.8.1-bp151.3.3.1

Ubuntu: new ansible packages.
New packages are available:
  Ubuntu 19.04: ansible 2.7.8+dfsg-1ubuntu0.19.04.1
  Ubuntu 18.04 LTS: ansible 2.5.1+dfsg-1ubuntu0.1
  Ubuntu 16.04 LTS: ansible 2.0.0.2-2ubuntu1.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability watch. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.