The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Ansible Core: privilege escalation via wrong creation of user directory

Synthesis of the vulnerability 

An attacker can control a user dedicated folder that should be created by Ansible Core, in order to escalate his privileges.
Impacted products: Ansible Core, Debian, Fedora.
Severity of this bulletin: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 12/03/2020.
Références of this threat: 67791, CVE-2020-10744, CVE-2020-1733, DLA-2202-1, FEDORA-2020-1b6ce91e37, FEDORA-2020-f80154b5b4, VIGILANCE-VUL-31773.

Description of the vulnerability 

An attacker can control a user dedicated folder that should be created by Ansible Core, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat announce impacts software or systems such as Ansible Core, Debian, Fedora.

Our Vigil@nce team determined that the severity of this computer vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity alert.

Solutions for this threat 

Ansible Core: version 2.9.7.
The version 2.9.7 is fixed:
  https://releases.ansible.com/ansible/ansible-2.9.7.tar.gz

Ansible Core: version 2.8.11.
The version 2.8.11 is fixed:
  https://releases.ansible.com/ansible/ansible-2.8.11.tar.gz

Ansible Core: version 2.7.17.
The version 2.7.17 is fixed:
  https://releases.ansible.com/ansible/ansible-2.7.17.tar.gz

Ansible Core: solution for user directory.
The solution is not yet known.
  - VIGILANCE-SOL-72396: version 2.7.17
  - VIGILANCE-SOL-72397: version 2.8.11
  - VIGILANCE-SOL-72398: version 2.9.7

Debian 8: new ansible packages.
New packages are available:
  Debian 8: ansible 1.7.2+dfsg-2+deb8u3

Fedora 30, 31: new ansible packages.
New packages are available:
  Fedora 30: ansible 2.9.7-1.fc30
  Fedora 31: ansible 2.9.7-1.fc31
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides system vulnerability alerts. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.