The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache Subversion: assertion error via svnserve get-deleted-rev

Synthesis of the vulnerability 

An attacker can force an assertion error via svnserve get-deleted-rev of Apache Subversion, in order to trigger a denial of service.
Impacted software: Subversion, Debian, Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 3/4.
Creation date: 01/08/2019.
Références of this announce: bulletinoct2019, CVE-2018-11782, DLA-1903-1, DSA-4490-1, FEDORA-2019-f6bc68e455, openSUSE-SU-2019:1910-1, RHSA-2020:3972-01, RHSA-2020:4712-01, SUSE-SU-2019:2031-1, SUSE-SU-2019:2032-1, USN-4082-1, VIGILANCE-VUL-29920.

Description of the vulnerability 

An attacker can force an assertion error via svnserve get-deleted-rev of Apache Subversion, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability alert impacts software or systems such as Subversion, Debian, Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness alert is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this computer vulnerability.

Solutions for this threat 

Apache Subversion: version 1.12.1.
The version 1.12.1 is fixed:
  http://subversion.apache.org/download.cgi

Apache Subversion: version 1.10.5.
The version 1.10.5 is fixed:
  http://subversion.apache.org/download.cgi

Apache Subversion: version 1.9.11.
The version 1.9.11 is fixed:
  http://subversion.apache.org/download.cgi

Apache Subversion: patch for svnserve get-deleted-rev.
A patch is indicated in information sources.

Debian 8: new subversion packages.
New packages are available:
  Debian 8: subversion 1.8.10-6+deb8u7

Debian 9/10: new subversion packages.
New packages are available:
  Debian 9: subversion 1.9.5-1+deb9u4
  Debian 10: subversion 1.10.4-1+deb10u1

Fedora 30: new subversion packages.
New packages are available:
  Fedora 30: subversion 1.12.2-1.fc30

openSUSE Leap: new subversion packages.
New packages are available:
  openSUSE Leap 15.0: subversion 1.10.6-lp150.7.1
  openSUSE Leap 15.1: subversion 1.10.6-lp151.4.3.1

Oracle Solaris: patch for third party software of October 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.8: new subversion packages.
New packages are available:
  RHEL 7.0-7.8: subversion 1.7.14-16.el7

RHEL 8: new subversion-1.10 module.
The following module is updated:
  RHEL 8 Module: subversion:1.10

SUSE LE 12 SP4: new subversion packages.
New packages are available:
  SUSE LE 12 SP4: subversion 1.8.19-25.9.1

SUSE LE 15: new subversion packages.
New packages are available:
  SUSE LE 15 RTM: subversion 1.10.6-3.6.2
  SUSE LE 15 SP1: subversion 1.10.6-3.6.2

Ubuntu 16.04: new subversion packages.
New packages are available:
  Ubuntu 16.04 LTS: subversion 1.9.3-2ubuntu1.3

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.
This bulletin fixes more than 100 vulnerabilities, but only the 100 recent vulnerabilities were associated to this bulletin.

Wind River Linux: version 10.18.44.12.
The version 10.18.44.12 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerability alerts. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.