The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache Subversion: denial of service via mod_authz_svn

Synthesis of the vulnerability 

An attacker can trigger a fatal error via mod_authz_svn of Apache Subversion, in order to trigger a denial of service.
Vulnerable systems: Subversion, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.
Severity of this threat: 2/4.
Creation date: 10/02/2021.
Références of this weakness: CVE-2020-17525, DSA-4851-1, FEDORA-2021-16e51e39a6, FEDORA-2021-a3a0273cb2, openSUSE-SU-2021:0280-1, RHSA-2021:0507-01, RHSA-2021:0508-01, RHSA-2021:0509-01, SUSE-SU-2021:0424-1, SUSE-SU-2021:0425-1, VIGILANCE-VUL-34544.

Description of the vulnerability 

An attacker can trigger a fatal error via mod_authz_svn of Apache Subversion, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability bulletin impacts software or systems such as Subversion, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this security note is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this cybersecurity note.

Solutions for this threat 

Apache Subversion: version 1.14.1.
The version 1.14.1 is fixed:
  https://subversion.apache.org/download.cgi#supported-releases

Apache Subversion: version 1.10.7.
The version 1.10.7 is fixed:
  https://subversion.apache.org/download.cgi#supported-releases

Debian 10: new subversion packages.
New packages are available:
  Debian 10: subversion 1.10.4-1+deb10u2

Fedora 32: new subversion packages.
New packages are available:
  Fedora 32: subversion 1.14.1-1.fc32

Fedora 33: new subversion packages.
New packages are available:
  Fedora 33: subversion 1.14.1-1.fc33

openSUSE Leap 15.2: new subversion packages.
New packages are available:
  openSUSE Leap 15.2: subversion 1.10.6-lp152.2.9.1

RHEL 8.0-8.2: new subversion-1.10 module.
The following module is updated:
  RHEL 8.0-8.2 Module: subversion:1.10

SUSE LE 12 SP5: new subversion packages.
New packages are available:
  SUSE LE 12 SP5: subversion 1.10.6-3.3.1

SUSE LE 15 RTM-SP3: new subversion packages.
New packages are available:
  SUSE LE 15 RTM: subversion 1.10.6-3.15.1
  SUSE LE 15 SP1: subversion 1.10.6-3.15.1
  SUSE LE 15 SP2: subversion 1.10.6-3.15.1
  SUSE LE 15 SP3: subversion 1.10.6-3.15.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a systems vulnerabilities workaround. The technology watch team tracks security threats targeting the computer system.