The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache Tomcat: code execution via Enabled AJP Connector

Synthesis of the vulnerability 

An attacker can use a vulnerability via Enabled AJP Connector of Apache Tomcat, in order to run code.
Vulnerable systems: Tomcat, Debian, Fedora, FreeIPA, HP-UX, MariaDB ~ precise, MySQL Community, MySQL Enterprise, openSUSE Leap, Oracle Communications, Oracle DB, Solaris, Percona Server, RHEL, JBoss EAP by Red Hat, SAP ERP, NetWeaver, SUSE Linux Enterprise Desktop, SLES.
Severity of this threat: 3/4.
Creation date: 24/02/2020.
Revision date: 06/05/2021.
Références of this weakness: bulletinapr2020, CERTFR-2020-AVI-112, cpujul2020, CVE-2020-1938, DLA-2133-1, DLA-2209-1, DSA-4673-1, DSA-4680-1, FEDORA-2020-04ac174fa9, FEDORA-2020-c870aa8378, HPESBUX04015, openSUSE-SU-2020:0345-1, openSUSE-SU-2020:0597-1, RHSA-2020:0855-01, RHSA-2020:0912-01, RHSA-2020:1478-01, RHSA-2020:1479-01, RHSA-2020:2779-01, RHSA-2020:2780-01, RHSA-2020:2781-01, RHSA-2020:2783-01, RHSA-2020:2840-01, SUSE-SU-2020:0598-1, SUSE-SU-2020:0631-1, SUSE-SU-2020:0632-1, SUSE-SU-2020:0725-1, SUSE-SU-2020:1111-1, SUSE-SU-2020:1126-1, SUSE-SU-2020:1272-1, SUSE-SU-2020:14342-1, VIGILANCE-VUL-31664.

Description of the vulnerability 

An attacker can use a vulnerability via Enabled AJP Connector of Apache Tomcat, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness alert impacts software or systems such as Tomcat, Debian, Fedora, FreeIPA, HP-UX, MariaDB ~ precise, MySQL Community, MySQL Enterprise, openSUSE Leap, Oracle Communications, Oracle DB, Solaris, Percona Server, RHEL, JBoss EAP by Red Hat, SAP ERP, NetWeaver, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this computer vulnerability note is important.

The trust level is of type confirmed by the editor, with an origin of intranet client.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this security bulletin.

Solutions for this threat 

Apache Tomcat: version 9.0.31.
The version 9.0.31 is fixed:
  https://tomcat.apache.org/whichversion.html

Apache Tomcat: version 8.5.51.
The version 8.5.51 is fixed:
  https://tomcat.apache.org/whichversion.html

Apache Tomcat: version 7.0.100.
The version 7.0.100 is fixed:
  https://tomcat.apache.org/whichversion.html

Apache Tomcat: workaround for Enabled AJP Connector.
A workaround is indicated in the information source.

Debian 10: new tomcat9 packages.
New packages are available:
  Debian 10: tomcat9 9.0.31-1~deb10u1

Debian 8: new tomcat7 packages.
New packages are available:
  Debian 8: tomcat7 7.0.56-3+really7.0.100-1

Debian 8: new tomcat8 packages.
New packages are available:
  Debian 8: tomcat8 8.0.14-1+deb8u17

Debian 9: new tomcat8 packages.
New packages are available:
  Debian 9: tomcat8 8.5.54-0+deb9u1

Fedora: new tomcat packages.
New packages are available:
  Fedora 30: tomcat 9.0.31-2.fc30
  Fedora 31: tomcat 9.0.31-2.fc31

FreeIPA: version 4.8.5.
The version 4.8.5 is fixed:
  http://www.freeipa.org/page/Downloads

HP-UX Tomcat: version 7.0.104.01.
The version 7.0.104.01 is fixed:
  https://myenterpriselicense.hpe.com/cwp-ui/free-software/HPUXWSATW509

MariaDB: versions 10.1.46, 10.2.33, 10.3.24, 10.4.14 and 10.5.5.
Versions 10.1.46, 10.2.33, 10.3.24, 10.4.14 and 10.5.5 are fixed:
  https://downloads.mariadb.org/mariadb/10.5.5
  https://downloads.mariadb.org/mariadb/10.4.14
  https://downloads.mariadb.org/mariadb/10.3.24
  https://downloads.mariadb.org/mariadb/10.2.33
  https://downloads.mariadb.org/mariadb/10.1.46

openSUSE Leap 15.1: new apache2 packages.
New packages are available:
  openSUSE Leap 15.1: apache2 2.4.33-lp151.8.12.1

openSUSE Leap 15.1: new tomcat packages.
New packages are available:
  openSUSE Leap 15.1: tomcat 9.0.31-lp151.3.12.1

Oracle Communications: CPU of July 2020.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2681987.1
  https://support.oracle.com/rs?type=doc&id=2682459.1
  https://support.oracle.com/rs?type=doc&id=2682014.1
  https://support.oracle.com/rs?type=doc&id=2683787.1
  https://support.oracle.com/rs?type=doc&id=2683788.1
  https://support.oracle.com/rs?type=doc&id=2683789.1
  https://support.oracle.com/rs?type=doc&id=2682045.1
  https://support.oracle.com/rs?type=doc&id=2683831.1
  https://support.oracle.com/rs?type=doc&id=2682010.1
  https://support.oracle.com/rs?type=doc&id=2683832.1
  https://support.oracle.com/rs?type=doc&id=2682500.1
  https://support.oracle.com/rs?type=doc&id=2683241.1
  https://support.oracle.com/rs?type=doc&id=2682011.1
  https://support.oracle.com/rs?type=doc&id=2683840.1
  https://support.oracle.com/rs?type=doc&id=2682018.1
  https://support.oracle.com/rs?type=doc&id=2683841.1
  https://support.oracle.com/rs?type=doc&id=2683842.1
  https://support.oracle.com/rs?type=doc&id=2683843.1
  https://support.oracle.com/rs?type=doc&id=2683845.1

Oracle Database: CPU of July 2020.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2664876.1

Oracle MySQL: version 5.6.49.
The version 5.6.49 is fixed:
  https://support.oracle.com/rs?type=doc&id=2683189.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL: version 5.7.31.
The version 5.7.31 is fixed:
  https://support.oracle.com/rs?type=doc&id=2683189.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle MySQL: version 8.0.21.
The version 8.0.21 is fixed:
  https://support.oracle.com/rs?type=doc&id=2683189.1
  https://www.mysql.com/fr/downloads/
  https://dev.mysql.com/downloads/mysql/

Oracle Solaris: patch for third party software of April 2020 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Percona Server for MySQL: version 5.6.49-89.0.
The version 5.6.49-89.0 is fixed:
  https://www.percona.com/

Red Hat JBoss EAP 6.4: patch for Tomcat.
A patch is available:
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=6.4

Red Hat JBoss EAP: version 6.4.23.
The version 6.4.23 is fixed:
  https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.4/index.html
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=6.4

RHEL 6.10: new tomcat6 packages.
New packages are available:
  RHEL 6.10: tomcat6 6.0.24-114.el6_10

RHEL 7.6: new tomcat packages.
New packages are available:
  RHEL 7.6: tomcat 7.0.76-10.el7_6

RHEL 7.7: new tomcat packages.
New packages are available:
  RHEL 7.7: tomcat 7.0.76-11.el7_7

SAP: solution of June 2020.
The solution is available on the SAP site:
  https://support.sap.com/securitynotes

SUSE LE 11: new apache2 packages.
New packages are available:
  SUSE LE 11 SP4: apache2 2.2.34-70.27.1
  SUSE LE 11 SP3: apache2 2.2.34-70.27.1

SUSE LE 12: new apache2 packages.
New packages are available:
  SUSE LE 12 SP1: apache2 2.4.16-20.29.1
  SUSE LE 12 SP2: apache2 2.4.23-29.54.1
  SUSE LE 12 SP3: apache2 2.4.23-29.54.1
  SUSE LE 12 SP4: apache2 2.4.23-29.54.1
  SUSE LE 12 SP5: apache2 2.4.23-29.54.1

SUSE LE 12: new tomcat packages.
New packages are available:
  SUSE LE 12 SP5: tomcat 9.0.31-3.25.1
  SUSE LE 12 SP4: tomcat 9.0.31-3.25.1

SUSE LE 12 SP2/3: new tomcat packages.
New packages are available:
  SUSE LE 12 SP2: tomcat 8.0.53-29.22.1
  SUSE LE 12 SP3: tomcat 8.0.53-29.22.1

SUSE LE 15: new apache2 packages.
New packages are available:
  SUSE LE 15 RTM: apache2 2.4.33-3.30.1
  SUSE LE 15 SP1: apache2 2.4.33-3.30.1

SUSE LE 15: new tomcat packages.
New packages are available:
  SUSE LE 15 RTM: tomcat 9.0.31-3.42.2
  SUSE LE 15 SP1: tomcat 9.0.31-4.22.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability note. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.