The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache Xerces Java: denial of service via hash collision

Synthesis of the vulnerability 

An attacker can send data generating storage collisions, in order to overload a service.
Impacted systems: Xerces Java, Puppet.
Severity of this alert: 2/4.
Creation date: 22/07/2014.
Références of this alert: 787104, CVE-2012-0881, VIGILANCE-VUL-15083.

Description of the vulnerability 

The bulletin VIGILANCE-VUL-11254 describes a vulnerability which can be used to create a denial of service on several applications.

This vulnerability also impacts Apache Xerces Java.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability alert impacts software or systems such as Xerces Java, Puppet.

Our Vigil@nce team determined that the severity of this computer threat alert is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this security vulnerability.

Solutions for this threat 

Puppet Enterprise: versions 2018.1.5 and 2019.0.1.
Versions 2018.1.5 and 2019.0.1 are fixed:
  https://puppet.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities alert. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.